Bug 990368 - Native Clients outside the trusted storage pool cannot mount a nufa volume
Native Clients outside the trusted storage pool cannot mount a nufa volume
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Vijay Bellur
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 00:55 EDT by Vijay Bellur
Modified: 2015-04-20 07:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:35:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2013-07-31 00:55:15 EDT
Description of problem:

Native Clients outside the trusted storage pool cannot mount a nufa volume as they do not find a local brick.

Version-Release number of selected component (if applicable): RHS 2.1


How reproducible:

Always


Steps to Reproduce:
1. Enable nufa on a volume (volume set <volname> cluster.nufa ON)
2. mount a native client in a node that is not part of the trusted storage pool
3. mount fails

Actual results:


Expected results:

mount should succeed.


Additional info:
Comment 3 Ravishankar N 2013-08-01 05:06:10 EDT
Back-ported one more patch against this bug:
https://code.engineering.redhat.com/gerrit/#/c/11013/

Without this patch, nufa mounts still fail:
===============================================================
[root@tuxpad glusterfs]# tail mnt-glusterfs.log
[2013-08-01 05:23:41.295226] I [glusterfsd.c:1970:main] 0-/usr/local/sbin/glusterfs: Started running /usr/local/sbin/glusterfs version 3.4rhs (/usr/local/sbin/glusterfs --volfile-id=HadoopVol --volfile-server=10.70.7.228 /mnt/glusterfs)
[2013-08-01 05:23:41.301352] I [socket.c:3487:socket_init] 0-glusterfs: SSL support is NOT enabled
[2013-08-01 05:23:41.301391] I [socket.c:3502:socket_init] 0-glusterfs: using system polling thread
[2013-08-01 05:23:41.307508] W [xlator.c:185:xlator_dynload] 0-xlator: /usr/local/lib/glusterfs/3.4rhs/xlator/cluster/nufa.so: undefined symbol: gf_is_same_address
[2013-08-01 05:23:41.307530] E [graph.y:211:volume_type] 0-parser: Volume 'HadoopVol-dht', line 50: type 'cluster/nufa' is not valid or not found on this machine
[2013-08-01 05:23:41.307539] E [graph.y:320:volume_end] 0-parser: "type" not specified for volume HadoopVol-dht
[2013-08-01 05:23:41.307555] E [glusterfsd.c:1834:glusterfs_process_volfp] 0-: failed to construct the graph
[2013-08-01 05:23:41.307614] W [glusterfsd.c:1062:cleanup_and_exit] (-->/usr/local/lib/libgfrpc.so.0(rpc_clnt_handle_reply+0x1ae) [0x7f7e9b578a59] (-->/usr/local/sbin/glusterfs(mgmt_getspec_cbk+0x32e) [0x40c946] (-->/usr/local/sbin/glusterfs(glusterfs_process_volfp+0x17a) [0x408580]))) 0-: received signum (0), shutting down
[2013-08-01 05:23:41.307630] I [fuse-bridge.c:6273:fini] 0-fuse: Unmounting '/mnt/glusterfs'.
[root@tuxpad glusterfs]#
=========================================
Comment 4 Rachana Patel 2013-08-13 05:05:24 EDT
able to mount volume from client(out side peer nodes) when NUFA is enabled.
Hence marking as verified.

Verified with 3.4.0.18rhs-1.el6rhs.x86_64
Comment 5 Scott Haines 2013-09-23 18:35:57 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.