Bug 990377 - RFE: Improve / replace the upload filename selector
RFE: Improve / replace the upload filename selector
Status: CLOSED WORKSFORME
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 01:37 EDT by Damian Jansen
Modified: 2015-08-06 01:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-11 02:43:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-07-31 01:37:33 EDT
Description of problem:
If you give a user a line edit to enter a file path, don't give them:
- a dialog to select a file, they are expecting to type
- a browse button if you go with the line edit selector
It's not very usable.

Version-Release number of selected component (if applicable):
Dev

How reproducible:
Easy always

Steps to Reproduce:
1. Go to Projects->Select a Project->select a Version
2. Press Source Documents, Upload Document
3. Click on the Upload dialog line edit

Actual results:
A dialog appears

Expected results:
Nothing, I should be allowed to type here

Additional info:
There seems to be a horrid focus battle at play here too - WebDriver can happily enter the text a user cannot, but the text from the linedit is ignored anyway and the exception of bug990373 occurs.
Comment 1 Damian Jansen 2013-07-31 01:39:51 EDT
Edit: scratch the additional info - it's a different exception!
Comment 2 David Mason 2013-08-02 00:33:38 EDT
This is the standard file upload element provided by the browser, so will differ a bit from browser to browser. Overriding the behaviour and style of this particluar element is somewhat hacky and is not straightforward, but would be nice to do if we find a stable and maintainable way to do so.
Comment 3 Damian Jansen 2014-03-06 19:39:35 EST
Switched to an RFE - make nice upload thingy

Note You need to log in before you can comment on or make changes to this bug.