Bug 990405 - Auto attach action not consistent in GUI and CLI when the system have more than one product installed
Auto attach action not consistent in GUI and CLI when the system have more th...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-07-31 02:44 EDT by xingge
Modified: 2016-09-19 22:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 15:10:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the waring screen shot. (77.70 KB, image/png)
2013-07-31 02:48 EDT, xingge
no flags Details

  None (edit)
Description xingge 2013-07-31 02:44:53 EDT
Description of problem:
Auto attach action not persist in GUI and CLI when the system have more than one product installed

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.8.14-1.el5
subscription-manager-firstboot-1.8.14-1.el5
subscription-manager-1.8.14-1.el5
python-rhsm-1.8.14-1.el5

How reproducible:
Always

Steps to Reproduce:
1.Install more than one product in one system, (cp product cert in /etc/pki/product)

2.Prepare an account that have subscriptions covered only one installed product. 

3.Use the account to register the system

4.Auto attach with CLI

5.remove all the subscriptions
#subscription-manager remove --all

5.Auto attach with GUI

Actual results:
1.After Auto attach with CLI,the subscription that cover the installed product was attached.
[root@localhost ~]# subscription-manager attach --auto
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux for SAP
Status:       Not Subscribed

Product Name: JBoss Enterprise Application Platform
Status:       Not Subscribed

Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

2.After auto attach with GUI, a error window pops up said "No service level will cover all installed products."
as the attachment.

Expected results:
When auto attach with GUI, the operation should succeed.

Additional info:
Comment 1 xingge 2013-07-31 02:48:28 EDT
Created attachment 780950 [details]
the waring screen shot.
Comment 2 Devan Goodwin 2013-08-06 15:10:35 EDT
This is probably working as expected. You have three installed products and an account that only has subscriptions to cover one of them.

The GUI design/requirements for autobind after service levels were introduced was that GUI autobind should abort if there is not an SLA which matches enough subscriptions to cover all installed products. 

The GUI autobind is meant to be a highly simplified tool for the most common desired outcome. The CLI and manual GUI attaching is the fallback where you can do partial, or non-SLA autobinds.

So unfortunately this is probably not a bug, the autobind behaviour is actually meant to behave slightly different in this case.

Please reopen if I've missed anything or there is a serious problem with this.

Note You need to log in before you can comment on or make changes to this bug.