This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 990408 - beakerd does not send mail: "TurboMail is not enabled!"
beakerd does not send mail: "TurboMail is not enabled!"
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.14
: ---
Assigned To: Dan Callaghan
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 02:52 EDT by Dan Callaghan
Modified: 2013-08-08 23:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 23:24:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2013-07-31 02:52:57 EDT
Description of problem:
beakerd does not send any mails (in particular, job completion notifications).

Version-Release number of selected component (if applicable):
0.14.0

Steps to Reproduce:
1. Configure mail correctly in /etc/beaker/server.cfg
2. Run beakerd

Actual results:
Notification mails are not sent.
Jul 22 08:05:15 beaker-devel beakerd[12013]: bkr.server.mail WARNING TurboMail is not enabled!

Expected results:
Mails are sent, no warnings about mail being disabled.

Additional info:
Regression in 0.14 due to removal of SIGHUP handling in beakerd. TurboMail's interface.start() is not being called.
Comment 1 Dan Callaghan 2013-07-31 02:56:34 EDT
On Gerrit: http://gerrit.beaker-project.org/2136
Comment 4 Dan Callaghan 2013-08-08 23:24:35 EDT
Beaker 0.14.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.