Bug 990425 - unit-tests need to fix occasional NPE failure in WebAdminHostPageServletTest
unit-tests need to fix occasional NPE failure in WebAdminHostPageServletTest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Nobody's working on this, feel free to take it
Pavel Novotny
ux
: CodeChange, ZStream
Depends On:
Blocks: 994100
  Show dependency treegraph
 
Reported: 2013-07-31 03:51 EDT by Einav Cohen
Modified: 2016-01-28 16:57 EST (History)
9 users (show)

See Also:
Fixed In Version: is9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 994100 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 13350 None None None Never

  None (edit)
Description Einav Cohen 2013-07-31 03:51:27 EDT
Description of problem:
The WebAdminHostPageServletTest unit test fails occasionally on Null Pointer Excetpion (NPE) - need to fix that.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Einav Cohen 2013-08-07 13:00:42 EDT
this bug has been opened originally due to a rhev-3.2 ci issue of occasional NPE failure in WebAdminHostPageServletTest (unit-test failure during compilation). 
Ohad - can you please confirm that there aren't any similar failures in the parallel rhev-3.3 ci job(s) and if so - move this BZ to VERIFIED?
Comment 3 Ohad Basan 2013-08-08 03:16:05 EDT
I don't see that failure occur in ci on the latest iterations
Comment 4 Einav Cohen 2013-08-08 09:49:17 EDT
(In reply to Ohad Basan from comment #3)
> I don't see that failure occur in ci on the latest iterations

thanks - moving to VERIFIED.
Comment 5 Itamar Heim 2014-01-21 17:24:25 EST
Closing - RHEV 3.3 Released
Comment 6 Itamar Heim 2014-01-21 17:25:15 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:28:49 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.