This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 990438 - gnfs: server nfs and unlock doesn't happen
gnfs: server nfs and unlock doesn't happen
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: santosh pradhan
:
Depends On: 921962
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 04:34 EDT by santosh pradhan
Modified: 2013-08-08 08:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 921962
Environment:
Last Closed: 2013-08-08 08:03:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-31 04:44:31 EDT
REVIEW: http://review.gluster.org/5442 (NFS: server nfs and unlock doesn't happen) posted (#1) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 2 santosh pradhan 2013-08-02 02:27:26 EDT
The fix is not needed. This is basically a configuration issue.

Problem description:
glusterd service conflicts with nfslock service. 

Description of FIX:
If the machine is going to run the Gluster NFS server, it's advised to stop the nfslock service (rpc.statd daemon) because Gluster NFS is going to start rpc.statd anyway. It is better to turn the nfslock service OFF through chkconfig or so to make it persistent across reboot.
Comment 3 santosh pradhan 2013-08-08 08:03:16 EDT
Am closing it. This is not a issue in code but a config issue.

Note You need to log in before you can comment on or make changes to this bug.