Bug 990442 - Formatting of flag changes might break an email address
Formatting of flag changes might break an email address
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Email Notifications (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 04:44 EDT by Tomas Capek
Modified: 2014-10-12 18:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 21:44:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Capek 2013-07-31 04:44:23 EDT
I just randomly checked the update to the email formatting and found another small bug:



           What    |Removed                     |Added
----------------------------------------------------------------------------
              Flags|needinfo?(tfonteyn@redhat.c |needinfo+
                   |om)                         |


( https://bugzilla.redhat.com/show_bug.cgi?id=983520 )

tfonteyn's email address above is split in two but the real problem is that only the first part "tfonteyn@redhat.c" is clickable in the email, pointing to

"mailto:tfonteyn@redhat.c"
Comment 1 Simon Green 2013-07-31 21:44:43 EDT
When sending e-mail, Bugzilla will split long lines at commas or spaces. In the above case, there is no comma or space to split on, so it has no option but to split at the 20th character. Your e-mail client (not Bugzilla) then decided to hyperlink the partial e-mail address.

The solution to the problem is to enable HTML e-mail (Under the preferences page). With HTML e-mail the e-mail address will be complete.

This code comes from upstream Bugzilla.

Note You need to log in before you can comment on or make changes to this bug.