Bug 990445 - (vim-mergetool) RFE: please add "mergetool" virtual provides
RFE: please add "mergetool" virtual provides
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
: Tracking
Depends On:
Blocks: 990444
  Show dependency treegraph
 
Reported: 2013-07-31 04:48 EDT by Karel Volný
Modified: 2015-09-22 06:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 990444
Environment:
Last Closed: 2015-09-22 06:14:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-07-31 04:48:23 EDT
please add

Provides: mergetool

for vim-enhanced and vim-X11

+++ This bug was initially created as a clone of Bug #990444 +++

There are some utilities that may require a tool to resolve merge conflicts. I refer to bug #982627 for example.

However, Fedora does not provide any common name which would satisfy the dependency, so the package has to require some exact package that provides appropriate tool.

This is less than optimal, because 1) the user preference for the tool used may be completely different than what the dependency pulls in, 2) the author/packager of the utility must keep track about the tool availability and possible conflicts.

The solution would be to create virtual Provides for each package providing the tool, so that the utility that needs it would require this virtual and not concrete package.

Let me propose "mergetool" as a name of this virtual.

- it is selfexplaining and, in addition, users of git are used to it, as there is "git mergetool" command which calls one of the available tools

- it doesn't seem to conflict with anything existing; the two important occurences are as a part of "PDF Merge Tool" name, which is clearly distinguished by the "pdf" prefix, and "Mergetool.com" as a company which provides its own "Mergetool" software that is strongly unlikely to appear in Fedora, if it deals with Microsoft NAV
Comment 1 Christopher Meng 2013-10-24 11:03:09 EDT
Any news here?

Thanks.
Comment 2 Karsten Hopp 2015-09-22 06:14:10 EDT
Provides: mergetool added in vim-7.4.873-1.fc24

Note You need to log in before you can comment on or make changes to this bug.