Bug 990446 - (diffuse-mergetool) RFE: please add "mergetool" virtual provides
RFE: please add "mergetool" virtual provides
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: diffuse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jon Levell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 990444
  Show dependency treegraph
 
Reported: 2013-07-31 04:50 EDT by Karel Volný
Modified: 2013-10-24 10:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: diffuse-0.4.7-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 990444
Environment:
Last Closed: 2013-08-06 19:37:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-07-31 04:50:33 EDT
please add

Provides: mergetool

for diffuse

+++ This bug was initially created as a clone of Bug #990444 +++

There are some utilities that may require a tool to resolve merge conflicts. I refer to bug #982627 for example.

However, Fedora does not provide any common name which would satisfy the dependency, so the package has to require some exact package that provides appropriate tool.

This is less than optimal, because 1) the user preference for the tool used may be completely different than what the dependency pulls in, 2) the author/packager of the utility must keep track about the tool availability and possible conflicts.

The solution would be to create virtual Provides for each package providing the tool, so that the utility that needs it would require this virtual and not concrete package.

Let me propose "mergetool" as a name of this virtual.

- it is selfexplaining and, in addition, users of git are used to it, as there is "git mergetool" command which calls one of the available tools

- it doesn't seem to conflict with anything existing; the two important occurences are as a part of "PDF Merge Tool" name, which is clearly distinguished by the "pdf" prefix, and "Mergetool.com" as a company which provides its own "Mergetool" software that is strongly unlikely to appear in Fedora, if it deals with Microsoft NAV
Comment 1 Christopher Meng 2013-07-31 06:50:23 EDT
Yes, when I use git mergetool I think there might need something. 

I'll fix it tomorrow.
Comment 2 Fedora Update System 2013-07-31 23:38:04 EDT
diffuse-0.4.7-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/diffuse-0.4.7-3.fc19
Comment 3 Fedora Update System 2013-07-31 23:39:08 EDT
diffuse-0.4.7-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/diffuse-0.4.7-3.fc18
Comment 4 Fedora Update System 2013-08-02 17:53:21 EDT
Package diffuse-0.4.7-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing diffuse-0.4.7-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14084/diffuse-0.4.7-3.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-06 19:37:05 EDT
diffuse-0.4.7-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-08-10 16:02:16 EDT
diffuse-0.4.7-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.