Bug 990449 - (meld-mergetool) RFE: please add "mergetool" virtual provides
RFE: please add "mergetool" virtual provides
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 990444
  Show dependency treegraph
 
Reported: 2013-07-31 04:52 EDT by Karel Volný
Modified: 2014-01-02 13:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 990444
Environment:
Last Closed: 2014-01-02 13:29:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-07-31 04:52:55 EDT
please add

Provides: mergetool

for meld

+++ This bug was initially created as a clone of Bug #990444 +++

There are some utilities that may require a tool to resolve merge conflicts. I refer to bug #982627 for example.

However, Fedora does not provide any common name which would satisfy the dependency, so the package has to require some exact package that provides appropriate tool.

This is less than optimal, because 1) the user preference for the tool used may be completely different than what the dependency pulls in, 2) the author/packager of the utility must keep track about the tool availability and possible conflicts.

The solution would be to create virtual Provides for each package providing the tool, so that the utility that needs it would require this virtual and not concrete package.

Let me propose "mergetool" as a name of this virtual.

- it is selfexplaining and, in addition, users of git are used to it, as there is "git mergetool" command which calls one of the available tools

- it doesn't seem to conflict with anything existing; the two important occurences are as a part of "PDF Merge Tool" name, which is clearly distinguished by the "pdf" prefix, and "Mergetool.com" as a company which provides its own "Mergetool" software that is strongly unlikely to appear in Fedora, if it deals with Microsoft NAV
Comment 1 Christopher Meng 2013-10-24 10:48:27 EDT
I think this bug can be solved easily, I've done this for diffuse package, you can do it, too.
Comment 2 Dominic Hopf 2014-01-02 13:29:00 EST
This change has been applied to Rawhide and will be merged with the next updates.

Note You need to log in before you can comment on or make changes to this bug.