Bug 990475 - Invalid state transition for task after submitting a lot of jobs and canceling some jobs.
Invalid state transition for task after submitting a lot of jobs and cancelin...
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
develop
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 05:25 EDT by xjia
Modified: 2015-07-19 20:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 19:52:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Raymond Mancy 2013-07-31 19:52:14 EDT
AFAICT this is not a bug and Beaker has dealt with an job submission script gone awry (by the locks of it) exactly as it was supposed to, and that is to catch these types of invalid state transitions.
Comment 3 xjia 2013-07-31 21:17:07 EDT
(In reply to Raymond Mancy from comment #2)
Hmm, the problem is why lock doesn't work, this thing should not happen. I assume some thing didn't protected correctly, although the program can handle the exception.

Note You need to log in before you can comment on or make changes to this bug.