Bug 990476 - Headpin Nightly : Attempt to remove a system more than once from system group works fine
Headpin Nightly : Attempt to remove a system more than once from system grou...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Tazim Kolhar
: Reopened, Triaged
Depends On:
Blocks: sam20-tracker 1010996
  Show dependency treegraph
 
Reported: 2013-07-31 05:26 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1010996 (view as bug list)
Environment:
Last Closed: 2014-07-02 10:14:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-07-31 05:26:02 EDT
Description of problem:
 Attempt to remove a system more than once from system group works fine

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.987.b81455e.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch
katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.987.b81455e.el6.noarch
katello-headpin-1.4.2-1.git.987.b81455e.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.987.b81455e.el6.noarch
katello-headpin-all-1.4.2-1.git.987.b81455e.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin --user-pass=*****

Steps to Reproduce:

1.Add a system to system group
# headpin -u admin -p **** system_group add_systems --name test_sys_group --org ACME_Corporation --system_uuids 8ac1fcfc-3c82-41a0-930d-de32a7b793dc
Successfully added systems to system group [ test_sys_group ]

2.Remove the system from the system group
# headpin -u admin -p admin system_group remove_systems --name test_sys_group --org ACME_Corporation --system_uuids 8ac1fcfc-3c82-41a0-930d-de32a7b793dc
Successfully removed systems from system group [ test_sys_group ]

3. Try to remove the same system once again from the system group
# headpin -u admin -p **** system_group remove_systems --name test_sys_group --org ACME_Corporation --system_uuids 8ac1fcfc-3c82-41a0-930d-de32a7b793dc
Successfully removed systems from system group [ test_sys_group ]

Actual results:
The command worked fine


Expected results:
The command should work fine but it should give as 'System [ UUID ]' not
found since now the system is already removed from the system group

Additional info:
Comment 1 Apurva Bhole 2013-08-06 13:29:41 EDT
The 'system_group remove_systems' command also gives incorrect message(Same one as above) if we try to remove a system(valid UUID) that is not present in the system group.
Comment 4 Brad Buckingham 2013-09-18 09:44:23 EDT
katello pull request:
https://github.com/Katello/katello-cli/pull/92

Refer to the PR for a description of the changes.
Comment 9 Mike McCune 2013-10-17 17:02:41 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 12 Tazim Kolhar 2014-05-08 02:42:54 EDT
VERIFIED
Comment 13 Bryan Kearney 2014-07-02 10:09:42 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.
Comment 14 Bryan Kearney 2014-07-02 10:09:49 EDT
This was delivered in 6.0.3, the Beta version of Satellite 6.0
Comment 15 Bryan Kearney 2014-07-02 10:14:35 EDT
This was delivered in the Satellite 6 Beta (6.0.3)

Note You need to log in before you can comment on or make changes to this bug.