Bug 990507 - virt-manager running on KDE do not show always CD-ROM connect box
virt-manager running on KDE do not show always CD-ROM connect box
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: 6.5
Assigned To: Martin Kletzander
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 06:34 EDT by Martin Schuppert
Modified: 2013-11-21 15:40 EST (History)
6 users (show)

See Also:
Fixed In Version: virt-manager-0.9.0-19.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 15:40:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 436733 None None None Never

  None (edit)
Description Martin Schuppert 2013-07-31 06:34:57 EDT
Description of problem:
Using virt-manager to connect a physical or ISO CD-ROM image do not always work on KDE. The "Choose Media" box to select the image or physical device do not always show up under KDE. This happens only with KDE. After changing to Gnome the issue were not seen any more.

Version-Release number of selected component (if applicable):
* RHEL 6.4 
* virt-manager-0.9.0-18.el6.x86_64

How reproducible:
occasional, but when the window do not show up for a VM it stays like this until the KVM host or libvirtd/virt-manager will be restarted.

Steps to Reproduce:
Using virt-manager:
1. create new VM (just one virtio disk and the IDE CD-ROM)
2. go to VM details -> IDE CDROM1
3. press "Connect" button

Actual results:
sometimes for a VM the "Choose Media" window do not show up. 

Expected results:
"Choose Media" window always shows up when press the "Connect" button.

Additional info:
This issue were not seen using newer upstream version virt-manager-0.9.1
Comment 2 Martin Kletzander 2013-07-31 07:49:08 EDT
This is most likely fixed upstream with RELEASE-0.9.0-1-79-g5efe079:

commit 5efe079158b7b6e1fb9e8fcc00af8b27a08dbde3
Author: Cole Robinson <crobinso@redhat.com>
Date:   Wed Jan 25 10:38:42 2012 -0500

    Top level windows shouldn't be visible by default
Comment 5 hyao@redhat.com 2013-08-07 05:09:17 EDT
I reproduced the bug with the following package:
Version: 
virt-manager-0.9.0-18.el6.x86_64

Set the host with KDE 
Steps to Reproduce:
1. create new VM (just one virtio disk and the IDE CD-ROM)
2. go to VM details -> IDE CDROM1
3. press "Connect" button

Actural result:
"Choose Media" window doesn't pop up every time.



Verified

Version 
virt-manager-0.9.0-19.el6.x86_64

Set the host with KDE 
Steps to Reproduce:
1. create new VM (just one virtio disk and the IDE CD-ROM)
2. go to VM details -> IDE CDROM1
3. press "Connect" button

Result:
"Choose Media" window  pops up every time.
Comment 6 errata-xmlrpc 2013-11-21 15:40:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1646.html

Note You need to log in before you can comment on or make changes to this bug.