Bug 990516 - Unmanaged VMs are reported in main host tab, but invisible in VMs subtab
Unmanaged VMs are reported in main host tab, but invisible in VMs subtab
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 07:14 EDT by Assaf Muller
Modified: 2013-08-01 03:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 03:21:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Assaf Muller 2013-07-31 07:14:44 EDT
Description of problem:
vdsClient -s 0 list table returns 2 VMs.
One was created via the engine, and the other via virsh (Not through the engine).

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.3.0_master
vdsm-4.12.0-rc3.15.gite62edfc.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install a new host
2. Create a VM through virsh
3. Create a 2nd VM through the engine

Actual results:
Hosts main tab reports 2 VMs on the host
VMs subtab reports only 1 VM (The one created through the engine)

Expected results:
The easy way out: Only report the VMs created through the engine
The better way - Show all VMS in the subtab. Ones not created through engine will be greyed out
The best way - Show all VMs in the subtab and allow management of all VMs, including ones not created through the engine
Comment 1 Assaf Muller 2013-07-31 07:17:05 EDT
Correction: It looks like the original VM was created via vdsClient or through another engine.
Comment 2 Itamar Heim 2013-08-01 03:21:14 EDT
i'm closing this as not a bug, since it is not currently a supported flow and is the expected behavior.
we are actually planning to fix this behavior for hosted engine soon.

Note You need to log in before you can comment on or make changes to this bug.