Bug 990519 - RPM not translating 'armhfp' to 'armv7hl' causing build failures in mingw packages
RPM not translating 'armhfp' to 'armv7hl' causing build failures in mingw pac...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-07-31 07:23 EDT by Daniel Berrange
Modified: 2013-08-09 13:01 EDT (History)
9 users (show)

See Also:
Fixed In Version: koji-1.8.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 13:01:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2013-07-31 07:23:44 EDT
Description of problem:
If any mingw* builds are unlucky enough to get scheduled on ARM builders in Koji, configure typically fails with the following error

  checking build system type... Invalid configuration `armhfp-redhat-linux-gnu': machine `armhfp-redhat' not recognized

eg  this mingw-libvirt build failure http://koji.fedoraproject.org/koji/taskinfo?taskID=5680000

In the thread here:

  https://lists.fedoraproject.org/pipermail/devel/2013-July/187156.html

It was suggested that the problem is rpm is not translating 'armhfp' to 'armv7hl'. It looks like redhat-rpm-config is responsible for setting up the default arch mappings in the rpmrc file. If i'm wrong feel free to re-assign the component or close as appropriate

Version-Release number of selected component (if applicable):
redhat-rpm-config-9.1.0-51.fc20

How reproducible:
Always

Steps to Reproduce:
1. Run a build of 'mingw-libvirt' in Koji, on an ARM builder host
2.
3.

Actual results:
  checking build system type... Invalid configuration `armhfp-redhat-linux-gnu': machine `armhfp-redhat' not recognized

Expected results:
Build succeeeds

Additional info:
Comment 1 Dennis Gilmore 2013-07-31 09:01:36 EDT
koji uses yums basearch for noarch builds. armhfp is not a valid arch for autoconf. arm and armv* are  we should have koji use arm instead of armhfp
Comment 2 Fedora Update System 2013-07-31 11:49:08 EDT
koji-1.8.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/koji-1.8.0-2.fc19
Comment 3 Fedora Update System 2013-08-01 23:26:45 EDT
Package koji-1.8.0-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing koji-1.8.0-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13948/koji-1.8.0-2.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-09 13:01:55 EDT
koji-1.8.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.