Bug 990528 - Bogus libmp-3.dll listed for mingw*-gmp
Bogus libmp-3.dll listed for mingw*-gmp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: msitools (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 07:57 EDT by Daniel Berrange
Modified: 2014-02-19 08:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-19 08:00:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2013-07-31 07:57:32 EDT
Description of problem:
The /usr/share/wixl-0.92.26-940f/include/gmp.wxi file shipped by msitools in Fedora 19 is broken, since it refers to a 'libmp-3.dll' file that no longer exists in the  mingw*gmp RPMs in Fedora 19.

        <Component Win64="$(var.Win64)" Id="cmpEBB0E822D6A0A44090A16AD807348C4D" Guid="*">
          <File Id="filB894F508D3E14768CA6FD1CE5457E6CA" KeyPath="yes" Source="$(var.SourceDir)/bin/libmp-3.dll"/>
        </Component>

can be removed.

Version-Release number of selected component (if applicable):
msitools-0.92.26-1.fc19.x86_64

How reproducible:
Alaways

Steps to Reproduce:
1. Attempt to build virt-viewer in F19 with msitols
2.
3.

Actual results:
Fails on non-existant libmp-3.dll

Expected results:
Passes

Additional info:
Comment 1 Marc-Andre Lureau 2014-02-19 08:00:07 EST
Fixed in upstream, v0.93-3-gcc3b74c, already in f20

Note You need to log in before you can comment on or make changes to this bug.