Bug 990537 - iLO2: Unable to login when password contains "
iLO2: Unable to login when password contains "
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks: 990539
  Show dependency treegraph
 
Reported: 2013-07-31 08:15 EDT by Marek Grac
Modified: 2014-10-14 03:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: fence-agents-3.1.5-43.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 990539 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:49:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Grac 2013-07-31 08:15:32 EDT
It is not possible to login to HP iLO2 when password contains characters that need to be escaped when used in XML attribute.

Unit test:
(before)

fence_ilo -o reboot -a test-ilo -z -l marx -p 'marx"marx'
Unable to connect/login to fencing device

(after)
fence_ilo -o reboot -a test-ilo -z -l marx -p 'marx"marx'
Comment 5 errata-xmlrpc 2014-10-14 03:49:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1562.html

Note You need to log in before you can comment on or make changes to this bug.