This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 990538 - file changed to symlink
file changed to symlink
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: thermostat (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 08:17 EDT by David Juran
Modified: 2013-07-31 14:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 14:16:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2013-07-31 08:17:02 EDT
Description of problem:
Updating from Fedora 17 with thermostat-0.3-1.fc17 to Fedora 19 with thermostat thermostat-0.9.2-4.fc19 fails since /usr/share/thermostat/agent/run (and a few other) changed from being a file to a symlink. These kind of changes aren't handled very well by rpm but need to be cleaned up manually.



How reproducible:
Every time

Steps to Reproduce:
1. install thermostat-0.3-1.fc17
2. yum update to latest F19 version
3.



Additional info:
The issue is similar in nature to Bug 976420
Comment 1 Severin Gehwolf 2013-07-31 14:16:44 EDT
Thanks for the bug report. At this point we can't really support dist-upgrades. The best you can do is (this will mean potential data loss):

sudo yum remove thermostat
rpm -qf /usr/share/thermostat (should not be owned by any package)
sudo yum remove /usr/share/thermostat.

Sorry about this, but we can't do much about this since upstream is still very much in flux too. In all fairness, upgrades from Fedora's where version # < latest - 1 is more than experimental terrain :)

Note You need to log in before you can comment on or make changes to this bug.