Bug 990575 - BPMS should not use system /tmp
BPMS should not use system /tmp
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.0.0
Assigned To: David Gutierrez
Jiri Svitak
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 09:30 EDT by Jiri Svitak
Modified: 2014-08-06 16:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:15:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ls -la /tmp (25.10 KB, text/plain)
2013-07-31 09:30 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-07-31 09:30:07 EDT
Created attachment 781133 [details]
ls -la /tmp

BPMS should not use system /tmp. Instead it should use for all temporary data tmp folder of the container, ie. jboss-eap-6.1/standalone/tmp.

Problematic files include
*.ser files
*.bpmn2 and other assets
gitz* they are from bpms as well, but I am not sure of their purpose
*.jar *.pom deployment units
..maybe others?

See the attached list of files in my /tmp dir.

There multiple problems which can be observed. Any fresh install of BPMS will still be affected by previous BPMS instances, which is undesired behavior.

/tmp is usually regularly deleted in many cases. Imagine situation where the server goes down, /tmp directory is deleted and system cannot reload active session id from .ser file.

Observed both in BPMS 6 DR6 and jBPM 6 CR1.
Comment 2 Jiri Svitak 2013-08-01 10:40:05 EDT
Hi Michael,
it's possible that some files may belong to dashbuilder, but can you please comment on other files mentioned?
(FYI bpms-perf is my project with assets for performance testing, it's not part of the product)
Comment 5 David Gutierrez 2013-09-05 11:26:13 EDT
As of dashbuilder, a fix was pushed on last July to avoid the creation of logs files under the /tmp directory: https://github.com/droolsjbpm/jbpm-dashboard/commit/a02b2e8649e5cfd5ee64a03a342716cef8f340c8


However, the application still creates some temporary files under /tmp: graphicElement*.tmp & csv_temp*.csv files which are created by invoking the File.createTempFile method and are marked as "deleteOnExit". So those files are truly temporal since are deleted just after the appserver shutdown. 

If we still want those kind of files to be created under the jboss tmp directory one possible way to proceed might be to modify the following java system property: jboss.io.tmpdir=<jboss tmp dir> to force java temp files to be created under the jboss tmp dir 

(to change system properties in JBoss please read https://community.jboss.org/wiki/JBossAS7SystemProperties)
Comment 9 Jiri Svitak 2013-10-15 11:48:27 EDT
David and Michael confirmed that the current files stored in system /tmp are truly temporary.

I consider this bug as verified. (BPMS 6 ER4)

If there will be again the same situation in the future, where a bpms instance will be affected by artifacts left from a previous one, new BZ will be filed.

Note You need to log in before you can comment on or make changes to this bug.