Bug 990579 - Invalid license, LGPL
Invalid license, LGPL
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pyudev (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 09:35 EDT by Jaroslav Škarvada
Modified: 2014-12-20 03:48 EST (History)
3 users (show)

See Also:
Fixed In Version: python-pyudev-0.15-7.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-20 03:48:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2013-07-31 09:35:05 EDT
Description of problem:
Invalid license, LGPL

Version-Release number of selected component (if applicable):
python-pyudev-0.15-4.fc20

How reproducible:
Always

Steps to Reproduce:
1. rpmlint python-pyudev

Actual results:
python-pyudev.noarch: W: invalid-license LGPL

Expected results:
No output regarding license.

Additional info:
Actually the code seems to be LGPLv2+. The upstream talks about LGPL in their docs, thus probably this should be also forwarded upstream.
Comment 1 Fedora End Of Life 2013-09-16 10:56:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora20
Comment 2 Fedora Admin XMLRPC Client 2014-12-10 13:38:10 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 David Shea 2014-12-10 14:06:35 EST
The upstream source already contains COPYING and boilerplate comments specifying that it can be distributed via the LGPL version 2.1 or newer, so I think all that needs to be done is change the string in the spec file.
Comment 4 Fedora Update System 2014-12-10 15:26:22 EST
python-pyudev-0.15-7.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-pyudev-0.15-7.fc21
Comment 5 Fedora Update System 2014-12-11 23:20:31 EST
Package python-pyudev-0.15-7.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-pyudev-0.15-7.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16677/python-pyudev-0.15-7.fc21
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-12-20 03:48:26 EST
python-pyudev-0.15-7.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.