Bug 990581 - [Doc] utilize gluster as a backend for glance w/ direct access to glusterfs from Nova (no http get needed)
[Doc] utilize gluster as a backend for glance w/ direct access to glusterfs f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: z2
: 4.0
Assigned To: Summer Long
ecs-bugs
: Documentation
Depends On: 988927
Blocks: 890211
  Show dependency treegraph
 
Reported: 2013-07-31 09:36 EDT by Stephen Gordon
Modified: 2014-03-16 19:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-03 19:04:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-07-31 09:36:40 EDT
Cloned for documentation impact, refer to Bug # 890211 for implementation details.
Comment 2 Don Domingo 2013-12-03 20:19:48 EST
adding parent BZ for relevance. BZ#988927 adds instructions on how to allow instances to bypass http-get when loading images if glance is also on the same host (ie load images from local FS). not sure if any further content is required as per this bug; will have to check if the term "local filesystem" excludes GlusterFS, in which case that will have to be corrected.

in any case, i'm de-prioritizing this item.
Comment 3 Don Domingo 2013-12-05 17:20:00 EST
Hi Flavio,

Does the usage of gluster as glance backend change the instructions we wrote for enabling image loading via local fs? e.g. do we have to specify a different value for "allowed_direct_url_schemes" in /etc/nova/nova.conf for it to understand the metadata exposed by glance?
Comment 4 Flavio Percoco 2013-12-05 18:12:41 EST
It does not change the instructions. 

We technically just support a fs backend. However, we can mount glusterfs and access it as it were a local filesystems. The bit to add to the documentation is that gluster needs to be mounted in both nodes glance's and nova's.
Comment 13 Don Domingo 2014-01-20 20:14:17 EST
Keeping this BZ open for ASYNC, just in case we can find someone to tech review the information herein. Since this is a low-impact docs change, we'll keep it in.
Comment 14 Don Domingo 2014-01-21 20:11:23 EST
Reassigning to you, Summer. The only remaining work here is getting the Nova part of the procedure tech-reviewed.

Note You need to log in before you can comment on or make changes to this bug.