Bug 990610 - After alerts disappear, user has no idea if validation is enabled/disabled
After alerts disappear, user has no idea if validation is enabled/disabled
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER3
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 10:25 EDT by Sona Mala
Modified: 2014-08-06 16:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sona Mala 2013-07-31 10:25:43 EDT
Description of problem:
CR1 contains a new feature that icon "Validation" is a drop down menu. This menu contains items:
  - Start validation
  - Stop validation
  - View all issues

All of these items are enabled every time, do not reflected a state of validation.

Version-Release number of selected component (if applicable):
6.0.0 CR1

Use Case 1
----------
Steps to Reproduce:
1. create a valid process
2. start validation 
3. wait until alert "Starting validation" disappears
4. show validation drop down menu

Actual results:
All items are enabled.
you have not any idea if visual validation is running or not.

Expected results:
Item "Start validation" is disabled and the others (Stop Validation, View all issues) are enabled.


Use Case 2
----------
Steps to Reproduce:
1. create any process
2. select "View all issues" in validation menu 
3. close editor
4. show validation drop down menu

Actual results:
All items are enabled.
Validation is still running (if you click on any invalid element, you get alert with issues)
Any invalid element is not highlighting.

you have not any idea if visual validation is running or not.

Expected results:
Item "Start validation" is disabled and the others (Stop Validation, View all issues) are enabled.

OR

Item "Stop validation" is disabled and the others (Start Validation, View all issues) are enabled. Because actions for "View all issues" are :
  - start validation
  - find out all issues
  - stop validation
  - shows the results

Additional info:
Comment 1 Tihomir Surdilovic 2013-08-26 13:11:41 EDT
this has been implemented in master and 6.0.x designer branches
Comment 2 Sona Mala 2013-09-19 05:31:21 EDT
Verified for ER3.

Note You need to log in before you can comment on or make changes to this bug.