Bug 990612 - network from external network provider shouldn't be displayed in setupNetwork.
network from external network provider shouldn't be displayed in setupNetwork.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
medium Severity high
: ---
: 3.3.0
Assigned To: Lior Vernia
Meni Yakove
network
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-07-31 10:35 EDT by Meni Yakove
Modified: 2016-02-10 14:55 EST (History)
9 users (show)

See Also:
Fixed In Version: is18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19820 None None None Never
oVirt gerrit 19821 None None None Never
oVirt gerrit 19822 None None None Never

  None (edit)
Description Meni Yakove 2013-07-31 10:35:35 EDT
Description of problem:
currently networks from external network provider shown in setupNetwork dialog but it's not allowed to attache them to host.
Networks from external network provider shouldn't be displayed in setupNetwork.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.11.master.el6ev.noarch

Steps to Reproduce:
1.create network on external network provider and attach it to cluster
2.open setupNetwork


Actual results:
The network is shown in setupNetwork

Expected results:
The network should.t be in setupNetwork.
Comment 1 Dan Kenigsberg 2013-08-02 03:53:00 EDT
Why shouldn't they be shown there? Because it clutters the GUI? I personally like to have plenty of information on dialog boxes...
Comment 2 Meni Yakove 2013-08-04 02:22:54 EDT
You can't attach external networks to interface in setupNetworks so they don't belong there if you can't use them.
Comment 3 Dan Kenigsberg 2013-08-04 05:37:13 EDT
Well I find seeing all networks useful (e.g. for telling me which network names are already taken), as long as it is clear which networks are native and which are provided. But let's let someone with GUI knowhow think about it.
Comment 4 Lior Vernia 2013-08-04 14:42:56 EDT
Well, I see both your points. Meni is correct that it is confusing to have networks that shouldn't be statically attached to NICs in a dialog that is used to statically attach networks to NICs. Dan is correct that it would be useful to see external networks, because it would help a user keep in mind that he may want to leave NICs free for these networks that might be attached dynamically.

So, may I offer two alternatives for a solution that will accommodate both views?
1. Somehow mark external networks, either by a different color or some icon.
AND / OR
2. Show an error message when external networks are dragged unto NICs (rather than allow the user to press OK and only then get an error - that probably should have been done anyway).

Best solution is to probably have both. Sound good?
Comment 5 Dan Kenigsberg 2013-08-04 15:20:39 EDT
(In reply to Lior Vernia from comment #4)
> 
> Best solution is to probably have both. Sound good?

Yes. For the benefit of the color-blind, I vote for "alien" icon 
Comment 6 Lior Vernia 2013-08-20 08:36:30 EDT
Having talked to a designer about this, the proposed solution is to have the external networks listed under a different category on the right-hand-side of the dialog with an explanation, to gray them out and to make them undraggable.
Comment 7 Meni Yakove 2013-10-13 03:47:16 EDT
rhevm-3.3.0-0.25.beta1.el6ev.noarch
Comment 8 Itamar Heim 2014-01-21 17:21:58 EST
Closing - RHEV 3.3 Released
Comment 9 Itamar Heim 2014-01-21 17:27:12 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.