Bug 990614 - Request for Prboom-Plus doom engine.
Request for Prboom-Plus doom engine.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: prboom (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On: 1026517
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 10:40 EDT by Simon Putt
Modified: 2016-01-31 20:58 EST (History)
2 users (show)

See Also:
Fixed In Version: prboom-plus-2.5.1.3-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-16 01:57:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Putt 2013-07-31 10:40:14 EDT
Request for GPL Doom engine called Prboom-Plus 2.5.1.3

Sources are here

http://prboom-plus.sourceforge.net/history.html

An example package for Mageia is here

http://mirror.internode.on.net/pub/mageia/distrib/cauldron/SRPMS/core/release/prboom-2.5.0-13.mga3.src.rpm

maybe it can be adapted to fedora?

It has the following features over prboom

Widescreen support
Better demo compatibility

Many more I cant remember right now, it is also still in development where prboom 2.5.0 seems to be dead.
Comment 1 Jaromír Cápík 2013-08-02 07:14:01 EDT
Hello Simon.

I started thinking about that several moths ago. Unfortunately the prboom-plus engine introduces also some regressions and that's why I don't want to drop the current engine. I'll schedule some testing this month and we'll see.

Regards,
Jaromir.
Comment 2 Simon Putt 2013-08-02 08:40:20 EDT
Nah no need to replace the current package. It would be nice to have both :)

Could you tell me some of the regressions? maybe you could take them up with the author?

Most of the reason I want this is because the current Prboom does not have wide-screen modes and on my 16:9 screen its all distorted and stretched and then there is all the new features and bug fixes that enable bigger levels etc that can not be played on the current prboom.

Many thanks for your help

Simon
Comment 3 Jaromír Cápík 2013-08-02 09:41:49 EDT
It was several months ago when I tested both engines in the local social and culture centre. I'm unsure if I remember the problems correctly, but I believe the plus engine started on both xinerama screens, so that it was too wide and split by the distance between both displays and it somehow resulted in no HW acceleration and too low framerate. That consequently caused keyboard control lockups and delays. I was even unable to quit the engine and it was impossible to switch that xinerama feature off and that made me angry. I finally uninstalled the package and returned back to the non-plus engine.
Comment 4 Fedora Update System 2013-11-07 11:29:14 EST
prboom-plus-2.5.1.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/prboom-plus-2.5.1.3-2.fc19
Comment 5 Fedora Update System 2013-11-07 11:29:30 EST
prboom-plus-2.5.1.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/prboom-plus-2.5.1.3-2.fc20
Comment 6 Fedora Update System 2013-11-07 14:05:48 EST
prboom-plus-2.5.1.3-2.fc20 has been pushed to the Fedora 20 testing repository.
Comment 7 Fedora Update System 2013-11-07 15:52:31 EST
prboom-plus-2.5.1.3-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/prboom-plus-2.5.1.3-3.fc20
Comment 8 Fedora Update System 2013-11-07 15:52:52 EST
prboom-plus-2.5.1.3-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/prboom-plus-2.5.1.3-3.fc19
Comment 9 Simon Putt 2013-11-07 15:53:11 EST
Thanks very much for responding to my request, I have tried the package on fedora 20 beta and its running fine I have tried all of the options and they work correctly, and I have tried all compatible wads (doom1/doom2/final dooms) and they also work as normal.
Comment 10 Jaromír Cápík 2013-11-07 15:55:42 EST
Hello Simon. 

I just submitted a new update that satisfies rpmlint. Could you please re-test with prboom-plus-2.5.1.3-3 and leave karma in bodhi?

Thanks,
Jaromir.
Comment 11 Simon Putt 2013-11-12 07:54:42 EST
seems libmad is missing as i cant play wads (extra levels) that contain MP3's, and also portmidi is missing.

could this be fixed please? many thanks.
Comment 12 Jaromír Cápík 2013-11-14 18:50:59 EST
Hello Simon.

Regarding the MP3 stuff ... I was expecting this question. This cannot be fixed due to the libmad licensing. The library has been removed from Rawhide and F20.
Someone should convert all the MP3 sounds to OGGs and edit the WADs so that they contain OGG sounds only.
I'll look at the portmidi stuff and let you know.

Thanks for letting me know.

Regards,
Jaromir.
Comment 13 Jaromír Cápík 2013-11-14 18:56:41 EST
And here's the fairy tale ... http://www.mp3-tech.org/patents.html
Comment 14 Jaromír Cápík 2013-11-14 19:07:32 EST
The MP3 stuff is still protected by 10 US patents and the latest will expire in 4 years ... in April 2017.

So ... it seems we have to wait a bit :]
Comment 15 Fedora Update System 2013-11-16 01:57:46 EST
prboom-plus-2.5.1.3-2.fc20 has been pushed to the Fedora 20 stable repository.
Comment 16 Fedora Update System 2013-11-16 01:59:03 EST
prboom-plus-2.5.1.3-2.fc19 has been pushed to the Fedora 19 stable repository.
Comment 17 Fedora Update System 2013-11-18 16:06:31 EST
prboom-plus-2.5.1.3-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-11-19 00:28:15 EST
prboom-plus-2.5.1.3-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.