This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 990632 - RHEL5: jansi.jar - META-INF/INDEX.LIST is missing
RHEL5: jansi.jar - META-INF/INDEX.LIST is missing
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RPMs (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: ER3
: EAP 6.2.0
Assigned To: David Walluck
Katerina Novotna
Russell Dickenson
:
Depends On:
Blocks: 1011318
  Show dependency treegraph
 
Reported: 2013-07-31 11:36 EDT by Pavel Janousek
Modified: 2015-02-20 06:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:15:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Janousek 2013-07-31 11:36:12 EDT
modules/system/layers/base/org/fusesource/jansi/main/jansi.jar doesn't contain a file META-INF/INDEX.LIST as the same artifact included in ZIP distro.
Comment 1 Fernando Nasser 2013-09-06 15:24:18 EDT
    INDEX.LIST

This file is generated by the new "-i" option of the jar tool, which contains location information for packages defined in an application or extension. It is part of the JarIndex implementation and used by class loaders to speed up their class loading process.

I wonder if there is an Ant attribute we can turn on...
Comment 2 David Walluck 2013-09-12 12:20:17 EDT
This is a Maven build, but it's currently built in Brew. Only native portions currently need to be built in Brew, so jansi itself could be moved to MEAD.

This report is talking about RHEL 5 vs. RHEL 6. Therefore, RHEL 6 has an index and RHEL 5 does not. They use the exact same code, so it's likely something else about the Brew root that is not identical, but due to the Brew log formats and missing log information this is nearly impossible to track.

Therefore, I think it's best to move this build to MEAD.
Comment 3 David Walluck 2013-09-17 14:03:34 EDT
I had to add index=true to the maven-jar-plugin archive configuration in the jansi pom.xml. It looks like that value should be inherited from jboss-component-management by default, but defining a local plugin section seems to override this value.
Comment 5 David Walluck 2013-09-18 13:14:14 EDT
Ideally, this could be added to the fusesource-pom instead as it is the parent pom for all fusesource projects. This would ensure various settings independent of jboss-component-management, but currently no rebuild of fusesource-pom is planned.

That said, I have moved the build to MEAD and this setting should be coming from jboss-parent/jboss-component-management now and not need an explicit setting. The setting is only needed if building without the current toolchain that has this enabled.
Comment 7 Pavel Janousek 2013-10-07 10:23:49 EDT
Fixed in EAP-6.2.0-ER3.

Note You need to log in before you can comment on or make changes to this bug.