Bug 990653 - [abrt] gimp-2.8.6-1.fc19: pango_ot_info_get: Process /usr/bin/gimp-2.8 was killed by signal 11 (SIGSEGV)
[abrt] gimp-2.8.6-1.fc19: pango_ot_info_get: Process /usr/bin/gimp-2.8 was ki...
Status: CLOSED DUPLICATE of bug 1053798
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
abrt_hash:50f61674658f11f76a21dbe1d8a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 12:17 EDT by Emmett Culley
Modified: 2014-02-10 03:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-10 03:54:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (63.84 KB, text/plain)
2013-07-31 12:18 EDT, Emmett Culley
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-31 12:18 EDT, Emmett Culley
no flags Details
File: core_backtrace (10.62 KB, text/plain)
2013-07-31 12:18 EDT, Emmett Culley
no flags Details
File: dso_list (9.98 KB, text/plain)
2013-07-31 12:18 EDT, Emmett Culley
no flags Details
File: environ (1.81 KB, text/plain)
2013-07-31 12:18 EDT, Emmett Culley
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-31 12:18 EDT, Emmett Culley
no flags Details
File: maps (50.89 KB, text/plain)
2013-07-31 12:18 EDT, Emmett Culley
no flags Details
File: open_fds (777 bytes, text/plain)
2013-07-31 12:18 EDT, Emmett Culley
no flags Details
File: proc_pid_status (958 bytes, text/plain)
2013-07-31 12:19 EDT, Emmett Culley
no flags Details
File: var_log_messages (321 bytes, text/plain)
2013-07-31 12:19 EDT, Emmett Culley
no flags Details
File: xsession_errors (871 bytes, text/plain)
2013-07-31 12:19 EDT, Emmett Culley
no flags Details

  None (edit)
Description Emmett Culley 2013-07-31 12:17:55 EDT
Description of problem:
I swiped the words that I was wanting to highlight in the text layer.  I might have swiped wider than the actual field of view, which closed the app.

Version-Release number of selected component:
gimp-2.8.6-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/bin/gimp-2.8 /home/denise/Places/graphics_and_pictures/FacebookPosts/XCF/Posts.xcf
crash_function: pango_ot_info_get
executable:     /usr/bin/gimp-2.8
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1001

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 pango_ot_info_get at pango-ot-info.c:81
 #1 gimp_font_get_sample_string at gimpfont.c:641
 #2 gimp_font_get_new_preview at gimpfont.c:274
 #3 gimp_viewable_get_preview at gimpviewable.c:741
 #4 gimp_viewable_real_get_new_pixbuf at gimpviewable.c:352
 #5 gimp_viewable_get_pixbuf at gimpviewable.c:911
 #6 gimp_view_renderer_real_render at gimpviewrenderer.c:753
 #7 gimp_view_renderer_real_draw at gimpviewrenderer.c:687
 #8 gimp_view_renderer_draw at gimpviewrenderer.c:606
 #9 gimp_cell_renderer_viewable_render at gimpcellrendererviewable.c:316

Potential duplicate: bug 834587
Comment 1 Emmett Culley 2013-07-31 12:18:19 EDT
Created attachment 781239 [details]
File: backtrace
Comment 2 Emmett Culley 2013-07-31 12:18:32 EDT
Created attachment 781240 [details]
File: cgroup
Comment 3 Emmett Culley 2013-07-31 12:18:41 EDT
Created attachment 781241 [details]
File: core_backtrace
Comment 4 Emmett Culley 2013-07-31 12:18:46 EDT
Created attachment 781242 [details]
File: dso_list
Comment 5 Emmett Culley 2013-07-31 12:18:48 EDT
Created attachment 781243 [details]
File: environ
Comment 6 Emmett Culley 2013-07-31 12:18:55 EDT
Created attachment 781244 [details]
File: limits
Comment 7 Emmett Culley 2013-07-31 12:18:57 EDT
Created attachment 781245 [details]
File: maps
Comment 8 Emmett Culley 2013-07-31 12:18:59 EDT
Created attachment 781246 [details]
File: open_fds
Comment 9 Emmett Culley 2013-07-31 12:19:10 EDT
Created attachment 781247 [details]
File: proc_pid_status
Comment 10 Emmett Culley 2013-07-31 12:19:18 EDT
Created attachment 781248 [details]
File: var_log_messages
Comment 11 Emmett Culley 2013-07-31 12:19:26 EDT
Created attachment 781250 [details]
File: xsession_errors
Comment 12 jose 2014-01-15 13:47:01 EST
Another user experienced a similar problem:

just need to choose another font diferent from default in gimp-2.8.10-4.fc19

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        /usr/bin/gimp-2.8 /home/jose/Dropbox/Marple-Covers/Miss_Marple_Coffret_1_Disc.png
crash_function: pango_ot_info_get
executable:     /usr/bin/gimp-2.8
kernel:         3.12.6-200.fc19.i686.PAE
package:        gimp-2.8.10-4.fc19
reason:         gimp-2.8 killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 13 Nils Philippsen 2014-01-20 11:43:01 EST
This is the same issue as bug #1053798 (Fedora 20). Changing component to pango as outlined there.
Comment 14 Akira TAGOH 2014-02-10 03:54:16 EST

*** This bug has been marked as a duplicate of bug 1053798 ***

Note You need to log in before you can comment on or make changes to this bug.