Bug 99067 - Unreliably dumping on large memory configuration
Unreliably dumping on large memory configuration
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: netdump (Show other bugs)
2.1
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Dave Anderson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-13 16:19 EDT by Need Real Name
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-24 14:48:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-07-13 16:19:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Windows NT 5.0; U)

Description of problem:
On large memory configurations (12-16GB) we are seeing server-timeouts when dumping memory resulting in dump that is 
smaller 
then physical memory.  Most dumps are less that 4GB is size.  It may not be important that the entire memory is dumped as long as 
we can reliably get a dump that large enough to analysis root cause of the crash.

These are typical errors we are seeing:

Jul  8 14:28:13 dse-rac1-db netdump[5537]: Got too many timeouts waiting for memory page for client  0x1e061886, ignoring it
Jul  8 14:28:17 dse-rac1-db netdump[5537]: Got too many timeouts waiting for SHOW_STATUS for client 0x1e061886, rebooting it

Version-Release number of selected component (if applicable):
vmlinuz-2.4.9-e.12enterprise

How reproducible:
Always

Steps to Reproduce:
1.Insmod crash.o
2.
3.
    

Actual Results:  Small dump, server timeouts

Expected Results:  Same size dump each time.  No timeouts.

Additional info
Comment 2 Dave Anderson 2004-02-11 16:17:18 EST
We are working on a reduced-memory tuneable, in which case netdump
will be configurable to *not* send free pages, user pages, and page
cache pages.




Note You need to log in before you can comment on or make changes to this bug.