Bug 99069 - libgnomeprint doesn't see all printers
libgnomeprint doesn't see all printers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-13 17:51 EDT by Trever Adams
Modified: 2007-04-18 12:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-07 12:53:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2003-07-13 17:51:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I have three printers.  One is a HP Laser Jet 6MP.  I use CUPS on my system and
the driver is a plain postscript one.  In 1.9.1 of Abiword, my printer doesn't
show up.  The other two do.  There is a generic postscript printer option, but
that won't print to the printer either.

My system is a half RedHat 9.0/half RedHat Rawhide.  All of the relevant
drivers, libraries, and Abiword are from Rawhide.

This may be a CUPS bug, but I don't think so.  I will be reporting this to
RedHat as well hoping it will get fixed.

See bug 3045 in Abiword Rawhide.  Again, I am not sure this is Abiword or cups
or something else.

Version-Release number of selected component (if applicable):
1.9.1 from rawhide

How reproducible:
Always

Steps to Reproduce:
Unsure, my other printers are Epson C80, and Epson Color Stylus 850.

I guess install all three printer drivers, and try to print a file from Abiword
1.9.1    

Actual Results:  Abiword doesn't show the HPLJ6MP in the list (that is the name
I gave it, btw.)

Expected Results:  It should show up.

Additional info:

There are VERY few files that are still RH9, the rest are Rawhide.
Comment 1 Trever Adams 2003-07-13 17:52:35 EDT
That is 3042 bug in Abiword's bugzilla, not in Abiword rawhide.  Sorry, a little
puncy I guess.  The 3045 was a typo.
Comment 2 Jeremy Katz 2003-07-14 18:59:53 EDT
This happens with any app using libgnomeprint (seen with gedit and evolution as
well)
Comment 3 Trever Adams 2003-07-14 19:05:25 EDT
Yes, I hadn't noticed that (I never print from gedit and rarely do from evolution.)

Anyone have any clues yet what happens?  Is this an off by one, or is this a hey
its postscript, ignore it?
Comment 4 Owen Taylor 2003-08-28 19:16:13 EDT
libgnomeprint won't list any cups printers for which it can't get the
PPD file.

This seems reasonable to me, though I suppose it could fall back to
assumming "generic postscript" in some fashion. But it seems to me
that that should be the responsibility of CUPS. 

Throwing this over to Tim Waugh for evaluation of why some printers
wouldn't get a response from cupsGetPPD(), and if anything can be
done about it.
Comment 5 Owen Taylor 2003-08-28 19:22:20 EDT
BTW, you should be able to add a PPD file for your printer

(http://www.linuxprinting.org/show_printer.cgi?recnum=HP-LaserJet_6MP)

with 

 lpadmin -pmy_printer -PHP-LaserJet_6MP.ppd 

or something close to that.
Comment 6 Trever Adams 2003-08-29 01:04:42 EDT
This is likely to be a wonderful work around.  However, this bug seems to have
been fixed in a recent rawhide or beta release.   About 2 weeks ago.  I have
been meaning to close this, so maybe it is time to close.

Comment 7 Tim Waugh 2003-08-29 05:49:21 EDT
Ever since redhat-config-printer was adapted to use CUPS, there should *always*
be a PPD associated with a queue.  Otherwise the queue won't work. :-)

So whatever the problem was, the fact that it went away without anything
substantial changing is scary.  I would need the output of 'printconf-tui
--Xexport' to find out why a queue isn't getting written out properly I think. 
Also, 'printconf-backend --force-rebuild' will force the configuration to be
written out again -- if that gives errors they would be useful to see.
Comment 8 Tim Waugh 2004-01-07 07:57:20 EST
*ping*
Comment 9 Trever Adams 2004-01-07 12:46:58 EST
I don't know what happened.  I can't really remember when this went
away.  But it is gone in Fedora Core 1 and in development for FC 2.

Note You need to log in before you can comment on or make changes to this bug.