Bug 990693 - Boinc Manager can't connect to Boinc Client
Boinc Manager can't connect to Boinc Client
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: boinc-client (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On: 1039258
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 14:59 EDT by Juan
Modified: 2014-01-04 20:38 EST (History)
4 users (show)

See Also:
Fixed In Version: boinc-client-7.2.33-2.git1994cc8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-27 00:58:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan 2013-07-31 14:59:44 EDT
Description of problem:

I installed lastest Fedora 19 boinc-client and boinc-manager.
I enabled and started boinc-client.service.
I added my user to boinc group.
I chmod g+rw all files in /var/lib/boinc directory.
I created a symbolic link in my home directory pointing to gui password file.
I allowed incoming connections to TCP port 31416 in the firewall.
I restarted the system.

When I start boinc manager, it constantly complains about not being able to connect to the client.
If I stop firewalld.service, then it can connect succesfully.

I also tried to open the same port for UDP (I haven't seen specified whether it's an UDP or TCP port, though I guessed it was TCP). The problem persists with UDP port open.

Version-Release number of selected component (if applicable):

7.0.65-1.git79b00ef.fc19 (x86_64) both for client and manager.


How reproducible:

Following the same steps described before.


Steps to Reproduce:
1. Install last stable version of boinc client and manager from official Fedora 19 repositories.
2. Add user to boinc group.
3. Provide read/write access for all files and directories under /var/lib/boinc (and this directory itself) to users belonging to boinc group.
4. Create a symbolic link in your home directory pointing to /var/lib/boinc/gui_rpc_auth.cfg and give it the same name.
5. Open port 31416 in firewall for incoming connections.
6. Enable and start boinc-client.service
7. To have your user effectively belong to boinc group, close and reopen the session. If you want to be 100% sure, just reboot the system after everything is done.
8. Run boincmgr.
(after failure)
9. Kill boincmgr.
10. Disable firewalld.service.
11. Run boincmgr.

Actual results:

boincmgr window opens and a popup complains about not being able to connect to localhost. Whenever you close the popup, it appears again almost immediately. The only way to close boincmgr is to kill boinc_gui process.
After disabling firewall, boincmgr works.

Expected results:

boincmgr opens normally and allows to connect to localhost without need to stop the firewall.

Additional info:

I believe creating symbolic link to password file (something I read and tried to see if it worked this way) makes it unnecessary to enter the password to connect to localhost, though I'm not sure. Anyway, if you disable the firewall and explicitly connect to localhost giving the password, when you restart the firewall the problem appears again.
Comment 1 Fedora Update System 2013-12-19 13:59:04 EST
boinc-client-7.2.33-2.git1994cc8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/boinc-client-7.2.33-2.git1994cc8.fc19
Comment 2 Fedora Update System 2013-12-19 13:59:40 EST
boinc-client-7.2.33-2.git1994cc8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/boinc-client-7.2.33-2.git1994cc8.fc20
Comment 3 Fedora Update System 2013-12-20 21:21:48 EST
Package boinc-client-7.2.33-2.git1994cc8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing boinc-client-7.2.33-2.git1994cc8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23720/boinc-client-7.2.33-2.git1994cc8.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-12-27 00:58:53 EST
boinc-client-7.2.33-2.git1994cc8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-12-27 00:59:53 EST
boinc-client-7.2.33-2.git1994cc8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Paul DeStefano 2014-01-04 20:34:57 EST
Boinc manager was working fine on system yesterday.  Then I did a yum update.  Now I have client and manager -7.2.33-2.git1994cc8.fc19.x86_64, but the manager cannot connect to the client.
Comment 7 Paul DeStefano 2014-01-04 20:38:38 EST
Oops.  So, this bug is for the bogus message "Cannot connect to client".  I have the inverse problem:  My manager cannot connect to the client, but does not report any error.  I guess I'll open a new bug.

Note You need to log in before you can comment on or make changes to this bug.