Bug 990699 - Headpin Nightly: Not able to upload manifest from stage
Headpin Nightly: Not able to upload manifest from stage
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-07-31 15:27 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:15:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Manifest upload UI error (61.90 KB, image/png)
2013-07-31 15:27 EDT, sthirugn@redhat.com
no flags Details
delayed_jobs.log (10.22 KB, text/plain)
2013-07-31 15:45 EDT, sthirugn@redhat.com
no flags Details
Delayed Job Log (59.38 KB, text/plain)
2013-08-06 03:27 EDT, Tazim Kolhar
no flags Details
Manifest attached (88.47 KB, application/zip)
2013-08-06 03:29 EDT, Tazim Kolhar
no flags Details
Screenshot attached (75.37 KB, image/png)
2013-08-06 03:30 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-07-31 15:27:59 EDT
Created attachment 781326 [details]
Manifest upload UI error

Description of problem:
Headpin Nightly: Not able to upload manifest from stage

Version-Release number of selected component (if applicable):
* candlepin-0.8.18-1.el6.noarch
* candlepin-cert-consumer-tyan-gt24-12.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-selinux-0.8.18-1.el6.noarch
* candlepin-tomcat6-0.8.18-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch
* katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
* katello-common-1.4.2-1.git.997.e699743.el6.noarch
* katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.997.e699743.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.997.e699743.el6.noarch
* katello-headpin-1.4.2-1.git.997.e699743.el6.noarch
* katello-headpin-all-1.4.2-1.git.997.e699743.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install headpin nightly
2. Launch the UI, create an ORG and try uploading a manifest from stage (recently generated from portal). I also attached the Manifest I used

Actual results:
Manifest upload fails with an error (UI screenshot attached)

Expected results:
Manifest uploaded successfully

Additional info:
Comment 2 sthirugn@redhat.com 2013-07-31 15:45:50 EDT
Created attachment 781331 [details]
delayed_jobs.log
Comment 4 Bryan Kearney 2013-08-02 15:24:11 EDT
Worked on SNAP0, moving to ON_QA.
Comment 5 Tazim Kolhar 2013-08-06 03:27:14 EDT
Created attachment 783220 [details]
Delayed Job Log

Failed ON_QA

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-common-1.4.3-5.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-cli-common-1.4.3-4.el6sat.noarch
katello-glue-elasticsearch-1.4.3-5.el6sam_splice.noarch
katello-headpin-all-1.4.3-5.el6sam_splice.noarch
katello-cli-1.4.3-4.el6sat.noarch
katello-glue-candlepin-1.4.3-5.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-5.el6sam_splice.noarch
Comment 6 Tazim Kolhar 2013-08-06 03:29:17 EDT
Created attachment 783221 [details]
Manifest attached
Comment 7 Tazim Kolhar 2013-08-06 03:30:41 EDT
Created attachment 783222 [details]
Screenshot attached
Comment 8 Tazim Kolhar 2013-08-08 03:37:54 EDT
Hi,

  I tried this again, after it was informed that
  this should work as expected.

  The upload is working for me.

  The contents of the delayed_job.log is :

   # tail -f delayed_job.log
# Logfile created on 2013-08-08 03:26:23 by logger.rb/31641
2013-08-08T03:26:23-0400: [Worker(delayed_job host:ibm-hs23-02.rhts.eng.bos.redhat.com pid:22666)] Starting job worker
2013-08-08T03:29:24-0400: [Worker(delayed_job host:ibm-hs23-02.rhts.eng.bos.redhat.com pid:22666)] Provider#queue_import_manifest completed after 5.2930
2013-08-08T03:29:24-0400: [Worker(delayed_job host:ibm-hs23-02.rhts.eng.bos.redhat.com pid:22666)] 1 jobs processed at 0.1870 j/s, 0 failed ...


  Please,let me know if I can change the BZ state to VERIFIED.
  Thanks !!
Comment 10 errata-xmlrpc 2013-10-01 07:15:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.