Bug 990703 - Evolution Unable to Use Gnome Keyring
Evolution Unable to Use Gnome Keyring
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 15:34 EDT by Jonathan Steffan
Modified: 2013-09-17 19:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 19:37:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Steffan 2013-07-31 15:34:09 EDT
Description of problem:
After update, all saved passwords were not being used and new passwords unable to be saved. Keyring manually cleared of all "evolution data source" entries and when trying to save a password no new entries were created.


Version-Release number of selected component (if applicable):
evolution-3.8.4-1.fc19.x86_64

How reproducible:
Always.


Steps to Reproduce:
1. Update.
2. Attempt to use a saved password or add a new password.
3.

Actual results:
No passwords are being used or saved.

Expected results:
Saved passwords work and new passwords are able to be saved.

Additional info:
Downgrade to evolution-3.8.3-2.fc19.x86_64 resolved the issue.
Comment 1 Milan Crha 2013-08-01 01:13:35 EDT
Thanks for a bug report. The evolution-source-registry process is responsible for the communication with the Gnome Keyring, I suppose if you restart it, together with other background evolution processes, after update, then it'll start working again.

Unfortunately, I do not know how to fix this on a packaging level, because processes like evolution-addressbook-factory, evolution-calendar-factory, evolution-alarm-notification and evolution itself talk to this evolution-source-registry process, and once the process is closed, it's notified to everyone that the sources are gone. It's more complicated with gnome-shell, where its calendar server restarts the calendar factory when it is stopped. That means, restart of the machine is the safest way to get the updated binaries in use here.
Comment 2 Jonathan Steffan 2013-09-17 19:37:27 EDT
evolution-3.8.5-2.fc19.x86_64 is what I am now running and am not experiencing this issue. I tend to agree this would be challenging to fix from a packager responsibility.

Note You need to log in before you can comment on or make changes to this bug.