Bug 990708 - Application fails in do_mmap_pgoff
Application fails in do_mmap_pgoff
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Larry Woodman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 15:46 EDT by Matthew Whitehead
Modified: 2013-08-12 23:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 23:15:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Whitehead 2013-07-31 15:46:37 EDT
Description of problem: When calling mmap64, a subroutine call to do_mmap_pgoff() appears to fail. A semaphore is also held and never released because of this failure, causing the application to hang.

Engineering suspects a failed call to make_pages_present() on line 1157 of mm/mmap.c may be a cause, but this requires more investigation.

The customer is running application with realtime priority 1 (lowest of the realtime priorities) using the FIFO scheduler. 32 cores on the host, 30 cores are used for the application.

They use the kernel parameter isolcpus=1-7,9-31 which is uncommon.


Version-Release number of selected component (if applicable): RHEL5.5 kernel 2.6.18-238.21.1.el5.


How reproducible: Four instances of this are believed to have happened to the customer.

Steps to Reproduce: Unknown.
1.
2.
3.

Actual results: 


Expected results: do_mmap_pgoff() should be successful.


Additional info:

Crash dump vmcore.00914556 uploading to dropbox.
Comment 1 Matthew Whitehead 2013-07-31 15:56:28 EDT
Correction: the line is really isolcpus=1,3-31 .
Comment 2 Matthew Whitehead 2013-08-01 09:53:51 EDT
Making bug public.
Comment 9 David Gibson 2013-08-12 23:15:16 EDT
Since we've identified this as an application / library interaction problem, I'm closing this as NOTABUG.

We can re-open if the customer finds a real RH bug in their further investigation.

Note You need to log in before you can comment on or make changes to this bug.