This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 99074 - Keyboard layout switcher breaks virtual terminal switching
Keyboard layout switcher breaks virtual terminal switching
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-13 21:25 EDT by Wagner T. Correa
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-23 04:56:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wagner T. Correa 2003-07-13 21:25:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
If I add a keyboard layout switcher applet to the gnome panel, ctrl-alt-f1,
ctrl-alt-f2, etc. no longer work, and I am unable to switch virtual terminals.

Version-Release number of selected component (if applicable):
gnome-applets-2.2.0-8

How reproducible:
Always

Steps to Reproduce:
1. Add a keyboard layout switcher applet to the gnome panel.
2. Press ctrl-alt-f1.


Actual Results:  Nothing will happen.

Expected Results:  Virtual terminal 1 should have appeared.

Additional info:

If I run xev, and I press ctrl-alt-f1, xev reports ctrl-alt-f11. If I remove the
keyboard layout switcher applet from the panel, everything goes back to normal.
I suspect it may be a bug in /usr/share/xmodmap/xmodmap.us.
Comment 1 Leo Lopes 2003-09-25 20:55:43 EDT
In addition to the desktop switching, in my case I also am unable to do Alt-Tab
switching between apps when I use the keyboard switching tool. The problem seems
to be with gkb_xmmap. If I use setxkbmap instead:

setxkbmap us_intl

instead of

gkb_xmmap us-int

even inside the gnome keyboard layout switcher, everything seems to be fine.
Sorry if it isn't the same bug...
Comment 2 David Kaplan 2003-09-26 15:25:40 EDT
I definitely have this same bug.  I switched the keyboard applet from using
gkb_xmmap to using setxkbmap and virtual terminals now work fine.  Doing this
seems to disable the new keyboard in terminals, but this is perhaps a benefit
since I rarely want a non-english character in a terminal.

Why are there soooo many ways to switch keyboards?  Is there a correct one to use?
Comment 3 Mark McLoughlin 2004-07-19 08:49:05 EDT
Is this still a problem in Fedora Core 2?
Comment 4 Wagner T. Correa 2004-07-22 15:48:41 EDT
This bug seems to be fixed in FC2.
Comment 5 Mark McLoughlin 2004-07-23 04:56:37 EDT
Thanks much for verifying that

Note You need to log in before you can comment on or make changes to this bug.