Bug 990752 - Anaconda errors should be shown in a popup window
Anaconda errors should be shown in a popup window
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 18:21 EDT by Dale R. Worley
Modified: 2013-08-07 20:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 20:18:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of a pop-up error window as generated by Adobe Reader 9 for Linux. (65.13 KB, image/jpeg)
2013-08-01 11:45 EDT, Dale R. Worley
no flags Details
screenshot showing evince reporting a "Not found" search result (231.49 KB, image/png)
2013-08-02 11:33 EDT, Steve Tyler
no flags Details
screenshot showing Manual Partitioning after specifying 50 GB and getting 1.28 GB (81.17 KB, image/png)
2013-08-02 12:52 EDT, Steve Tyler
no flags Details
screenshot showing Manual Partitioning with some logical volumes scheduled to be formatted (75.08 KB, image/png)
2013-08-02 15:30 EDT, Steve Tyler
no flags Details

  None (edit)
Description Dale R. Worley 2013-07-31 18:21:54 EDT
Description of problem:
Anaconda errors are (usually) reported in a strip across the bottom of the screen, rather than as a pop-up window.  The errors in the strip across the bottom can be difficult to spot.  This may be due to its visual resemblance to the bar across the bottom of the Windows GUI.  These days, it is commonest for GUI programs to report errors with a popup window.  It would make Anaconda less confusing and awkward to operate if it reported errors in popup windows.

Version-Release number of selected component (if applicable):
19.30.13-1
Comment 1 Steve Tyler 2013-08-01 00:03:09 EDT
What common GUI program do you regard as making good use of popup windows?
Comment 2 Steve Tyler 2013-08-01 00:21:52 EDT
I agree that the error messages in the bar are sometimes hard to identify as such ...

How did you discover that there are error messages in the bar along the bottom?
Specifically, what were you attempting to do?
Comment 3 Dale R. Worley 2013-08-01 11:42:54 EDT
> What common GUI program do you regard as making good use of popup windows?

I don't use a lot of GUI programs actually (as I'm a Linux weenie).  I do use Firefox a lot, though IIRC it doesn't pop-up a lot of *errors*, though it does pop-up file selection windows frequently.

IMO, an adequate method would be to copy Adobe Reader 9.5.5.04 for Linux.  I'll try to attach a screenshot of one of its error reports.

From a *marketing* point of view, slavishly following whatever Windows has been doing for 4 or 5 years would probably be best; that maximizes the chance that the naive user is familiar with the idiom.

> How did you discover that there are error messages in the bar along the bottom?
> Specifically, what were you attempting to do?

This is how I remember it:  I was in the Manual Partitioning window, I had selected a mount point for the new Linux installation, and I then inserted into the form on the right the information for the *existing* partition that I wanted to assign to that mount point.  I then clicked the "Apply" button (or whatever it's called).  At that point, my partition assignment was erased.

Only after doing this a few times did I discover that the bar at the bottom contained the error message.  I didn't notice whether the bar *appears* with the first error message, or whether it starts in some sort of non-error state.  But after the first error is made, any successive error does not cause a gross change to the appearance of the screen, so the eye is not drawn to it.  (Though it is quite startling that the "Apply" button causes the data I've entered to vanish and be replaced (IIRC) with a faint grey default value again -- but of course that's what I'm looking directly at at that time.)
Comment 4 Dale R. Worley 2013-08-01 11:45:03 EDT
Created attachment 781664 [details]
Example of a pop-up error window as generated by Adobe Reader 9 for Linux.
Comment 5 Dale R. Worley 2013-08-01 14:56:56 EDT
Example of the error bar on "Manual Partitioning":

Enter "Manual Partitioning" by:

1. At "Installation Destination" leave the default in place (the single disk in the system is selected).

2. Click "Done".

3. Pop-up "Installation Options" appears, warning that there is not enough free space available for the installation.

4. Click "Custom Partitioning".

5. At this point, there is no error bar at the bottom of the screen.

6. Click "+".

7. Pop-up "Add a new mount point" appears.

8. Enter "/" for "Mount Point".

9. Enter "50 GB" for "Desired Size".

10. Click "Add mount point".

11. Returns to "Manual Partitioning".

12. Error bar now shows with message "Added new LVM to existing container Hobgoblin00".

(But the partition size shown is only 1.408 GB, not the requested 50 GB, which should be flagged to the user.)
Comment 6 Steve Tyler 2013-08-02 07:25:41 EDT
(In reply to Dale R. Worley from comment #3)
...
> Only after doing this a few times did I discover that the bar at the bottom
> contained the error message.  I didn't notice whether the bar *appears* with
> the first error message, or whether it starts in some sort of non-error
> state.  But after the first error is made, any successive error does not
> cause a gross change to the appearance of the screen, so the eye is not
> drawn to it.  (Though it is quite startling that the "Apply" button causes
> the data I've entered to vanish and be replaced (IIRC) with a faint grey
> default value again -- but of course that's what I'm looking directly at at
> that time.)

Thanks, Dale. You are very insightful:

" ... after the first error is made, any successive error does not cause a gross change to the appearance of the screen, so the eye is not drawn to it."

The bug here, IMO, is that once the error bar is turned on, it stays on. The error bar needs to be reset somehow.
Comment 7 Steve Tyler 2013-08-02 07:49:27 EDT
Thanks for attaching the screenshot of the Adobe Reader popup[1]. It is a superb example, but not in the way you intended, so please don't take offense -- this is a critique of Adobe:

1. The popup obscures the center of the document.
2. The user has no other option than to click OK, or, possibly, quit Reader.
3. The popup is not reporting an error or a warning, but the result of a search.

Dialog Boxes
http://msdn.microsoft.com/en-us/library/windows/desktop/aa511268.aspx

"Modal dialog boxes"
"Use for critical or infrequent, one-off tasks that require completion before continuing."

IOW, Adobe is using the wrong GUI element here ...

[1] Microsoft would call it a "modal dialog box":
http://msdn.microsoft.com/en-us/library/windows/desktop/aa511273.aspx
Comment 8 Steve Tyler 2013-08-02 08:03:42 EDT
Apple also deprecates modal dialogs:

"Embrace Modelessness"

"Users appreciate apps that allow them to be in control and they generally dislike apps that wrest control away from them too often. One of the most common ways that apps take control away from users is by overusing modes that require users to follow a specific path."

OS X Human Interface Guidelines
User Experience Guidelines
https://developer.apple.com/library/mac/#documentation/UserExperience/Conceptual/AppleHIGuidelines/UEGuidelines/UEGuidelines.html#//apple_ref/doc/uid/TP40002720-TPXREF101
Comment 9 Dale R. Worley 2013-08-02 10:45:15 EDT
(In reply to Steve Tyler from comment #7)
> Thanks for attaching the screenshot of the Adobe Reader popup[1]. It is a
> superb example, but not in the way you intended, so please don't take
> offense -- this is a critique of Adobe:
> 
> 1. The popup obscures the center of the document.
> 2. The user has no other option than to click OK, or, possibly, quit Reader.
> 3. The popup is not reporting an error or a warning, but the result of a
> search.

The particular example I screenshotted was a "not found" message, but you seemed to be asking for what style I liked, and it was the nearest example to hand.  True, "not found" for a search isn't really an error, but that's beside the point:  My request is that Anaconda use modal error boxes to ensure that naive users don't overlook the error text.  As you say:

> "Modal dialog boxes"
> "Use for critical or infrequent, one-off tasks that require completion
> before continuing."

On a critically important program that the user will use maybe twice a year, you really do want to make sure that the user knows that what he requested has not happened before he blithely continues.

But maybe I'm mistaking your question.  Are you trying to get me to clarify what I'm asking for, or are you trying to get me to prove that there are other applications that do what I'm asking for?
Comment 10 Steve Tyler 2013-08-02 11:33:04 EDT
Created attachment 782021 [details]
screenshot showing evince reporting a "Not found" search result

I don't use Adobe Reader, because the Fedora document viewer, evince, works fine.

This screenshot shows that evince displays search progress and results in a box at the top of the window and that evince does not display a modal dialog when search text cannot be found.

NB: Evince is called "Document Viewer" on the Gnome desktop.

http://projects.gnome.org/evince/

Tested with:
$ rpm -q evince
evince-3.8.3-1.fc19.x86_64
Comment 11 Steve Tyler 2013-08-02 11:34:58 EDT
(In reply to Steve Tyler from comment #1)
> What common GUI program do you regard as making good use of popup windows?
                                                  ^^^^^^^^

The emphasis in my question is on "good use" -- in your opinion, of course ...
Comment 12 Steve Tyler 2013-08-02 11:45:00 EDT
(In reply to Steve Tyler from comment #10)
...
> This screenshot shows that evince displays search progress and results in a
> box at the top of the window ...
      ^^^^^^^^^^^^^^^^^^^^^^^^

Thanks for provoking me into attaching the evince screenshot ... :-)

The installer error messages are displayed at the bottom of the dialog.
Do you believe they would be more noticeable if they were displayed at the *top* of the dialog?
Comment 13 Steve Tyler 2013-08-02 12:09:08 EDT
(In reply to Dale R. Worley from comment #9)
...
> On a critically important program that the user will use maybe twice a year,
> you really do want to make sure that the user knows that what he requested
> has not happened before he blithely continues.
...

The installer does not let the user begin installation until the disk configuration is correct. That is not very clear from the GUI, though ...

The installer is not a mind-reader, however, so the user can unintentionally specify that a partition be formatted that the user did not want to be formatted. If the user specifies a wrong partition to be formatted, that is not an error that the installer can detect.

How much warning should the user be given when there will be data loss once installation begins?
Comment 14 Steve Tyler 2013-08-02 12:52:12 EDT
Created attachment 782072 [details]
screenshot showing Manual Partitioning after specifying 50 GB and getting 1.28 GB

(In reply to Dale R. Worley from comment #5)
> Example of the error bar on "Manual Partitioning":
> 
> Enter "Manual Partitioning" by:
...
> 11. Returns to "Manual Partitioning".
> 
> 12. Error bar now shows with message "Added new LVM to existing container
> Hobgoblin00".
> 
> (But the partition size shown is only 1.408 GB, not the requested 50 GB,
> which should be flagged to the user.)

Good catch. The installer is truncating the requested size to the available size. I reproduced that part, but did not get a message. I'm not sure if that is a bug or a feature, but I agree that the user should be notified with a warning. Could you open a new bug?

Abbreviated procedure:
1. Complete a minimal install with about 1 GB of disk space unallocated.
2. Restart the installer.
3. Add a new mount point:
    Mount Point:        /foo1
    Desired Capacity:   50 GB
Comment 15 Steve Tyler 2013-08-02 13:03:19 EDT
(In reply to Steve Tyler from comment #14)
...
> Good catch. The installer is truncating the requested size to the available
> size. I reproduced that part, but did not get a message. I'm not sure if
> that is a bug or a feature, but I agree that the user should be notified
> with a warning. Could you open a new bug?
...

Now I remember -- it is a feature. The user can allocate all remaining space by specifying a capacity that is larger than the available space. See the "Tips and hints" section of the Manual Partitioning help page.
Comment 16 Steve Tyler 2013-08-02 15:30:13 EDT
Created attachment 782145 [details]
screenshot showing Manual Partitioning with some logical volumes scheduled to be formatted

(In reply to Dale R. Worley from comment #9)
...
> On a critically important program that the user will use maybe twice a year,
> you really do want to make sure that the user knows that what he requested
> has not happened before he blithely continues.
...

The problem illustrated by this screenshot is that if the user "blithely continues", the wrong storage volume may be formatted:

The user is about to click "Done".
Which of these two logical volumes is scheduled to be formatted?

1. /valuable_data
2. /junk_i_dont_care_about

In fact, the Summary of Changes dialog that is displayed after clicking Done lets the user review everything that the installer is going to do.

NB: No irreversible changes occur until the user clicks Begin Installation.
Comment 17 Brian Lane 2013-08-07 20:18:55 EDT
We won't be going back to popups.

Note You need to log in before you can comment on or make changes to this bug.