Bug 990883 - No error messages show when input wrong spice password
Summary: No error messages show when input wrong spice password
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 990888
TreeView+ depends on / blocked
 
Reported: 2013-08-01 07:14 UTC by tingting zheng
Modified: 2013-11-21 08:11 UTC (History)
8 users (show)

Fixed In Version: virt-viewer-0.5.6-7
Doc Type: Bug Fix
Doc Text:
Cause: Enter invalid password for a Spice session. Consequence: No error dialog is shown. Fix: Handle authentication failure Result: Show an error dialog if Spice password is invalid
Clone Of:
: 990888 (view as bug list)
Environment:
Last Closed: 2013-11-21 08:11:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description tingting zheng 2013-08-01 07:14:42 UTC
Description
No error messages show when input wrong spice password

Version:
virt-viewer-0.5.6-6.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a spice guest,set password for spice.

2.Use virt-viewer to connect the guest.
# virt-viewer $guest

3.Input a wrong or blank password in the "Authentication" box,then press "OK".

4.No error messages show.

5.No such issue for vnc guest,when input wrong password,it will pop out error messages:
"Unable to authenticate with remote desktop server at 127.0.0.1:5902: Authentication failed,Retry connection again?"

Actual results:
No error messages show when input the wrong spice password.

Expected results:
Error messages show when input the wrong password for spice guests as vnc guests.

Additional info:

Comment 2 Marc-Andre Lureau 2013-08-02 14:56:25 UTC
I sent a patch to ML:
https://www.redhat.com/archives/virt-tools-list/2013-August/msg00006.html

Comment 4 tingting zheng 2013-08-21 06:43:34 UTC
Tested with:
virt-viewer-0.5.6-7.el6.x86_64

Steps:
1.Prepare a spice guest,set password for spice.

2.Use virt-viewer to connect the guest.
# virt-viewer $guest

3.Input a wrong or blank password in the "Authentication" box,then press "OK".
error shows:
Unable to authenticate with remote desktop server: invalid password

4.Press "OK",then the "Authentication" box shows again until you put the correct password or choose "Cancel".

Refer to the above comments,move the bug to VERIFIED.

Comment 5 errata-xmlrpc 2013-11-21 08:11:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.