Bug 990916 - subscription-manager-gui can not launch at the first time if register and then make ca cert invalid.
subscription-manager-gui can not launch at the first time if register and the...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.5
Assigned To: Devan Goodwin
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-08-01 04:23 EDT by qianzhan
Modified: 2013-11-21 16:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:27:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
'rhsm.log' (114.98 KB, text/x-log)
2013-08-01 04:26 EDT, qianzhan
no flags Details
'qianqian-Screenshot from 2013-08-01.png' (87.47 KB, image/png)
2013-08-01 04:27 EDT, qianzhan
no flags Details

  None (edit)
Description qianzhan 2013-08-01 04:23:46 EDT
Description of problem:
subscription-manager-gui can not launch at the first time if register and then make ca cert invalid.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-1.8.14-1.el5
subscription-manager-gui-1.8.14-1.el5
subscription-manager-1.8.14-1.el5
python-rhsm-1.8.15-1.el5

How reproducible:
90%

Steps to Reproduce:
1.Prepare to register to SAM
[root@dhcp-65-82 ~]# cat /etc/rhsm/rhsm.conf
hostname = samserv.redhat.com
baseurl= https://samserv.redhat.com:8088

2.Register to SAM
[root@dhcp-65-82 ~]# subscription-manager clean
All local data removed
[root@dhcp-65-82 ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: b83f50ee-10dc-4664-b41f-5d177283f14a 

3.Mv ca cert out of /etc/rhsm/ca
[root@dhcp-65-82 ~]# ls /etc/rhsm/ca/
candlepin-local.pem  candlepin-stage.pem  redhat-uep.pem
[root@dhcp-65-82 ~]# mv /etc/rhsm/ca/* ./

4.Refresh and open gui
[root@dhcp-65-82 ~]# subscription-manager refresh
Your identity certificate has expired
[root@dhcp-65-82 ~]# subscription-manager-gui 

[root@dhcp-65-82 ~]# 

Actual results:
subscription-manager-gui can not launch at the first time if register and then make ca cert invalid.

Expected results:
subscription-manager-gui can launch with invalid ca cert

Additional info:
Additional steps based on step 4:
5.Move the ca cert back to /etc/rhsm/ca and gui can be opened
[root@dhcp-65-82 ~]# mv *.pem /etc/rhsm/ca
[root@dhcp-65-82 ~]# subscription-manager refresh
All local data refreshed
[root@dhcp-65-82 ~]# subscription-manager-gui 

(subscription-manager-gui:15091): libglade-WARNING **: unknown property `has_tooltip' for class `GtkButton'

(subscription-manager-gui:15091): libglade-WARNING **: unknown property `has_tooltip' for class `GtkEventBox'

(subscription-manager-gui:15091): libglade-WARNING **: unknown property `primary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:15091): libglade-WARNING **: unknown property `secondary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:15091): libglade-WARNING **: unknown property `primary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:15091): libglade-WARNING **: unknown property `secondary_icon_sensitive' for class `GtkEntry'

6.Mv ca cert out of /etc/rhsm/ca again, and gui can be opened.
[root@dhcp-65-82 ~]# mv /etc/rhsm/ca/* ./
[root@dhcp-65-82 ~]# subscription-manager refresh
certificate verify failed
[root@dhcp-65-82 ~]# subscription-manager-gui 

(subscription-manager-gui:15136): libglade-WARNING **: unknown property `has_tooltip' for class `GtkButton'

(subscription-manager-gui:15136): libglade-WARNING **: unknown property `has_tooltip' for class `GtkEventBox'

(subscription-manager-gui:15136): libglade-WARNING **: unknown property `primary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:15136): libglade-WARNING **: unknown property `secondary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:15136): libglade-WARNING **: unknown property `primary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:15136): libglade-WARNING **: unknown property `secondary_icon_sensitive' for class `GtkEntry'

rhsm.log file is attached as 'rhsm.log'
screenshot of this issue is attached as 'qianqian-Screenshot from 2013-08-01.png'
Comment 1 qianzhan 2013-08-01 04:26:22 EDT
Created attachment 781470 [details]
'rhsm.log'
Comment 2 qianzhan 2013-08-01 04:27:13 EDT
Created attachment 781472 [details]
'qianqian-Screenshot from 2013-08-01.png'
Comment 3 Bryan Kearney 2013-08-01 08:56:06 EDT
moving to rhel 6.5 since this requires manual shenanigans.
Comment 5 Devan Goodwin 2013-08-07 12:32:54 EDT
Seems to have been fixed by other work, problem no longer appears in latest 5.10 build or master, though I can see it with older builds. (1.8.9 for example)

Behaves more like connectivity problem, GUI will start, but status will be grey icons for Unknown.
Comment 6 qianzhan 2013-08-08 01:28:55 EDT
Verified!

[root@dhcp-65-82 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 1.4.2-17.el6sam_splice-Headpin
subscription-manager: 1.8.14-1.el5
python-rhsm: 1.8.15-1.el5
[root@dhcp-65-82 ~]# subscription-manager clean
All local data removed
[root@dhcp-65-82 ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: f7e06bf0-219a-4f9f-9c31-71f423985d41 
[root@dhcp-65-82 ~]# mv /etc/rhsm/ca/* ./
[root@dhcp-65-82 ~]# subscription-manager refresh
certificate verify failed
[root@dhcp-65-82 ~]# subscription-manager-gui 

(subscription-manager-gui:4713): libglade-WARNING **: unknown property `has_tooltip' for class `GtkButton'

(subscription-manager-gui:4713): libglade-WARNING **: unknown property `has_tooltip' for class `GtkEventBox'

(subscription-manager-gui:4713): libglade-WARNING **: unknown property `primary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:4713): libglade-WARNING **: unknown property `secondary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:4713): libglade-WARNING **: unknown property `primary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:4713): libglade-WARNING **: unknown property `secondary_icon_sensitive' for class `GtkEntry'
Comment 7 qianzhan 2013-08-08 01:31:17 EDT
(In reply to qianzhan from comment #6)
> Verified!
> 
> [root@dhcp-65-82 ~]# subscription-manager version
> server type: Red Hat Subscription Management
> subscription management server: 1.4.2-17.el6sam_splice-Headpin
> subscription-manager: 1.8.14-1.el5
> python-rhsm: 1.8.15-1.el5
> [root@dhcp-65-82 ~]# subscription-manager clean
> All local data removed
> [root@dhcp-65-82 ~]# subscription-manager register
> Username: admin
> Password: 
> The system has been registered with ID: f7e06bf0-219a-4f9f-9c31-71f423985d41 
> [root@dhcp-65-82 ~]# mv /etc/rhsm/ca/* ./
> [root@dhcp-65-82 ~]# subscription-manager refresh
> certificate verify failed
> [root@dhcp-65-82 ~]# subscription-manager-gui 
> 
> (subscription-manager-gui:4713): libglade-WARNING **: unknown property
> `has_tooltip' for class `GtkButton'
> 
> (subscription-manager-gui:4713): libglade-WARNING **: unknown property
> `has_tooltip' for class `GtkEventBox'
> 
> (subscription-manager-gui:4713): libglade-WARNING **: unknown property
> `primary_icon_activatable' for class `GtkEntry'
> 
> (subscription-manager-gui:4713): libglade-WARNING **: unknown property
> `secondary_icon_activatable' for class `GtkEntry'
> 
> (subscription-manager-gui:4713): libglade-WARNING **: unknown property
> `primary_icon_sensitive' for class `GtkEntry'
> 
> (subscription-manager-gui:4713): libglade-WARNING **: unknown property
> `secondary_icon_sensitive' for class `GtkEntry'

I don't know why I can not mark this bug to status 'VERIFIED', and I'll mark it once I am entitled.
Comment 8 Li Bin Liu 2013-08-08 01:52:05 EDT
According to Comment #6, closed this bug as VERIFIED.

Thanks,
Libin
Comment 10 errata-xmlrpc 2013-11-21 16:27:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.