Bug 990927 - Incorrect time format of examples in oo-admin-usage man page.
Incorrect time format of examples in oo-admin-usage man page.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 04:37 EDT by Liang Xia
Modified: 2015-05-14 20:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:49:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liang Xia 2013-08-01 04:37:58 EDT
Description of problem:
oo-admin-usage allows -s|--start|-e|--end timeframe, which should be in format yyyy-mm-dd, but the examples show:
$ oo-admin-usage -l bob@redhat.com -s 1360790232 -e 136079383

Version-Release number of selected component (if applicable):
devenv_3598

How reproducible:
always

Steps to Reproduce:
1.check the man page of oo-admin-usage
2.
3.

Actual results:
The example show:
$ oo-admin-usage -l bob@redhat.com -s 1360790232 -e 136079383

Expected results:
Time frame should be in format yyyy-mm-dd

Additional info:
Comment 1 Abhishek Gupta 2013-08-13 16:24:59 EDT
Fixed in --> https://github.com/openshift/origin-server/pull/3345
Comment 3 Liang Xia 2013-08-13 22:17:51 EDT
Verfied on devenv_3646, the time format defect has been fixed.
$ oo-admin-usage -l bob@redhat.com -s 2013-08-01 -e 2013-08-15

But move back to assigned as another small typo was caused by this fix.

The dot between oo-admin-usage and (8) is not needed:
oo-admin-usage.(8)                                          oo-admin-usage.(8)


Code change caused this is:
-.TH oo-admin-usage 8 "11 April 2013" "" ""
+.TH oo-admin-usage. 8 "13 August 2013" "" ""
Comment 5 Abhishek Gupta 2013-08-14 14:25:17 EDT
Was a typo in the txt2man command that I used to generate the file.

Fixed with --> https://github.com/openshift/origin-server/pull/3357
Comment 6 Jianwei Hou 2013-08-15 00:06:43 EDT
Verified on devenv_3653
Checked man page, it's updated as:

      List the usage for the user within a specified timeframe:

           $ oo-admin-usage -l bob@redhat.com -s 2013-08-01 -e 2013-08-15

...............
AUTHOR
       Adam Miller <admiller@redhat.com> - man page written for OpenShift Origin

                                14 August 2013               oo-admin-usage(8)

Note You need to log in before you can comment on or make changes to this bug.