Bug 990933 - Can't resize window after leave full-screen
Can't resize window after leave full-screen
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: metacity (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Owen Taylor
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 04:54 EDT by CongDong
Modified: 2017-12-06 07:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:55:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The screenshot for the sharp edge window (2.66 MB, image/png)
2013-08-01 04:57 EDT, CongDong
no flags Details
The virt-viewer log file. (7.63 KB, text/plain)
2013-08-01 04:58 EDT, CongDong
no flags Details

  None (edit)
Description CongDong 2013-08-01 04:54:26 EDT
Description of problem:
Sometimes, after I leave full screen , I can't resize one of the two windows, and "Minimize Window" "Maximize Window" button on the title bar can't work too.

Version-Release number of selected component (if applicable):
spice-gtk-0.20-3.el6.x86_64
virt-viewer-0.5.6-6.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-glib-0.20-3.el6.x86_64
libvirt-0.10.2-21.el6.x86_64
qemu-kvm-0.12.1.2-2.382.el6.x86_64

How reproducible:
10%

Steps to Reproduce:
1.Prepare a machine with two physical monitors.
2.Create a rhel guest with spice+qxl+spicevmc
3.# remote-viewer spice://$ip:$port --full-screen=auto-conf --debug
4.Make sure can see the two displays of guest are full-screen on each monitor.
5.Click "Leave fullscreen", after leave fullscreen , can see two guest displays, check the title bar, and try to resize the window.

Actual results:
1. After leave fullscreen, can't resize one of the windows
2. The edge of the window looks sharp, but gnome windows are mellow.
But if drag the title bar to move the window, the edge will be ok.

Expected results:
After leave fullscreen, every window of guest should be ok, can resize it, and no sharp edge.

Additional info:
1. I can reproduce this with command "virt-viewer $guest" too
2. If I click "View->zoom->zoom in(or out)", then the window will be all right, can resize it as usual.
Comment 1 CongDong 2013-08-01 04:57:48 EDT
Created attachment 781483 [details]
The screenshot for the sharp edge window
Comment 2 CongDong 2013-08-01 04:58:36 EDT
Created attachment 781484 [details]
The virt-viewer log file.
Comment 4 Marc-Andre Lureau 2013-08-02 11:16:56 EDT
The window border and titlebar are drawn by metacity.

fwiw, I can't reproduce (0/10)
Comment 5 CongDong 2013-08-06 05:05:58 EDT
(In reply to Marc-Andre Lureau from comment #4)
> The window border and titlebar are drawn by metacity.
> 
> fwiw, I can't reproduce (0/10)

I remembered it could be reproduced easy, but I tried again today, and it's hard to reproduce, the frequency is about (2/40), but the problem is existing.
Comment 6 RHEL Product and Program Management 2013-10-13 19:18:43 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 8 Jan Kurik 2017-12-06 07:55:28 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.