Bug 990970 - DEBUG_TIME_FORMAT ignored by condor
DEBUG_TIME_FORMAT ignored by condor
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Erik Erlandson
Tomas Rusnak
:
Depends On:
Blocks: 1045236
  Show dependency treegraph
 
Reported: 2013-08-01 06:13 EDT by Tomas Rusnak
Modified: 2014-04-02 16:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 08:32:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Rusnak 2013-08-01 06:13:23 EDT
Description of problem:
The time format in condor logs should be configured by DEBUG_TIME_FORMAT. By setting such parameter nothing changed in the condor logs.

Version-Release number of selected component (if applicable):
$CondorVersion: 7.8.8 Feb 01 2013 BuildID: RH-7.8.8-0.4.1.el6 $
$CondorPlatform: X86_64-RedHat_6.3 $

How reproducible:
100%

Steps to Reproduce:
1. set, for example, CONDOR_DEBUG=D_ALL and DEBUG_TIME_FORMAT="%m/%d/%y %H:%M:%S %A"
2. activate configuration in wallaby, or restart condor
3. you can see there are no day of the week (strftime supported %A parameter) as required:
08/01/13 06:12:12 Return from Timer handler 2841 (CCBServer::PollSockets) - took 0.000s
08/01/13 06:12:12 Calling Timer handler 5 (self_monitor)
08/01/13 06:12:12 Getting monitoring info for pid 11182
08/01/13 06:12:12 Return from Timer handler 5 (self_monitor)

Actual results:
the DEBUG_TIME_FORMAT is ignored

Expected results:
DEBUG_TIME_FORMAT should change logs time format
Comment 1 Matthew Farrellee 2013-08-02 18:01:06 EDT
Is DEBUG_TIME_FORMAT ignored or is %A not honored?

$ condor_version
$CondorVersion: 7.8.8 Mar 15 2013 BuildID: RH-7.8.8-0.11.el6 $
$CondorPlatform: X86_64-RedHat_6.3 $

$ _CONDOR_TOOL_DEBUG=D_ALL _CONDOR_DEBUG_TIME_FORMAT="%A - " condor_status -debug -negotiator 2>&1 | head -n1
Friday - (fd:3) (pid:20899) config: using subsystem 'TOOL', local ''
Comment 2 Tomas Rusnak 2013-08-05 04:21:42 EDT
%A was not honored. But, I tried another formats, too. The time format was still the same (default).
Comment 3 Erik Erlandson 2014-02-04 12:56:25 EST
I'm failing to reproduce this.  I configured:

CONDOR_DEBUG=D_ALL
DEBUG_TIME_FORMAT="%y-%m-%d %H:%M:%S "

And the configured format change shows up in all the log files:

========================================================
$ head -3 *Log
==> CollectorLog <==
14-02-04 10:50:59 OpSysMajorVersion:  18 
14-02-04 10:50:59 OpSysShortName:  Fedora 
14-02-04 10:50:59 OpSysLongName:  Fedora release 18 (Spherical Cow) 

==> MasterLog <==
14-02-04 10:50:59 OpSysMajorVersion:  18 
14-02-04 10:50:59 OpSysShortName:  Fedora 
14-02-04 10:50:59 OpSysLongName:  Fedora release 18 (Spherical Cow) 

==> MatchLog <==
14-02-04 10:51:00 Setting maximum accepts per cycle 8.
14-02-04 10:51:00 ******************************************************
14-02-04 10:51:00 ** condor_negotiator (CONDOR_NEGOTIATOR) STARTING UP

==> NegotiatorLog <==
14-02-04 10:51:00 OpSysMajorVersion:  18 
14-02-04 10:51:00 OpSysShortName:  Fedora 
14-02-04 10:51:00 OpSysLongName:  Fedora release 18 (Spherical Cow) 

==> SchedLog <==
14-02-04 10:51:00 (pid:27998) OpSysMajorVersion:  18 
14-02-04 10:51:00 (pid:27998) OpSysShortName:  Fedora 
14-02-04 10:51:00 (pid:27998) OpSysLongName:  Fedora release 18 (Spherical Cow) 

==> StarterLog <==
14-02-04 10:51:01 OpSysMajorVersion:  18 
14-02-04 10:51:01 OpSysShortName:  Fedora 
14-02-04 10:51:01 OpSysLongName:  Fedora release 18 (Spherical Cow) 

==> StartLog <==
14-02-04 10:51:01 OpSysMajorVersion:  18 
14-02-04 10:51:01 OpSysShortName:  Fedora 
14-02-04 10:51:01 OpSysLongName:  Fedora release 18 (Spherical Cow)
Comment 4 Tomas Rusnak 2014-02-06 05:01:18 EST
Which condor version are you using for reproduction? It was reported on:

$CondorVersion: 7.8.8 Feb 01 2013 BuildID: RH-7.8.8-0.4.1.el6 $
$CondorPlatform: X86_64-RedHat_6.3 $

Let me try to reproduce it again, but it looks solved on current release.
Comment 5 Tomas Rusnak 2014-02-06 08:32:39 EST
I can't reproduce it now. Original system is not available anymore. It should be reopened when this will happen again. Thanks Erik

Note You need to log in before you can comment on or make changes to this bug.