Bug 991 - Package is built with unusual options limiting its usefulness
Package is built with unusual options limiting its usefulness
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-28 23:11 EST by tomek
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-06 16:12:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tomek 1999-01-28 23:11:23 EST
Binary RPMs of ImageMagick were built with the unusual
option which makes ImageMagic use 16 bits per Red, Green and
Blue channels (48 bits all together) rather then the usual 8
bits per channel (24 bits all together).

This doesn't affect ImageMagic tools in any way but affects
the ability of other image processing tools included with
5.1 (and 5.2) distribution to process files produced by
ImageMagick utilities. In particular, none of the netpbm
tools included as part of the libgr package can process pnm
files produced by ImageMagick tools. Any proprietary
software written to use libppm fails to read ppm files
produced by ImageMagick tools. Since most image processing
utilities use the 8-bits-per-channel standard I think that
ImageMagic binaries should be recompiled to use the same
standard.

All that needs to be changed is the following line from
ImageMagic.spec:

%build
CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 \
        --enable-shared --enable-16bit-pixel \
        --with-perl --with-x $RPM_ARCH-redhat-linux

Remove "--enable-16bit-pixel" option from compilation
instructions.
Comment 1 David Lawrence 1999-04-06 15:50:59 EDT
Your suggestion has been passed on to a developer for further review.
Comment 2 Michael K. Johnson 1999-04-06 16:12:59 EDT
I agree that it is a bug.
I have fixed it in ImageMagick-4.2.2-3

Note You need to log in before you can comment on or make changes to this bug.