Bug 991010 - xlock need to enter password twice
xlock need to enter password twice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xlockmore (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 07:53 EDT by Alick Zhao
Modified: 2014-01-19 14:05 EST (History)
3 users (show)

See Also:
Fixed In Version: xlockmore-5.43-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-05 01:01:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of xlock debug mode (375.16 KB, image/png)
2013-09-11 10:52 EDT, Alick Zhao
no flags Details
xlock never unlocks from :0.1 (8.07 KB, image/png)
2013-12-22 12:09 EST, Seb L.
no flags Details
Proposed fix for bug #991010 (1018 bytes, patch)
2013-12-22 18:03 EST, Seb L.
no flags Details | Diff

  None (edit)
Description Alick Zhao 2013-08-01 07:53:07 EDT
Description of problem:
In Fedora 19, when using xlock to lock the screen, I need to type the password twice to unlock it. After I type the password once, a prompt appears in the middle of the screen, asking the password again.

Version-Release number of selected component (if applicable):
xlockmore-5.43-1.fc19

How reproducible:
Always

Steps to Reproduce:
1. Open a terminal, and type 'xlock' to go to the lock screen.
2. Click any key to the interface to enter the password.
3. Type the password, then Enter key. Another password prompt appears.
4. Type the password the second time. Back to the unlocked screen.

Actual results:
As described above, you need to type the password twice.

Expected results:
Only once is needed, which is the case in Fedora 18 with xlockmore 5.41-1.

Additional info:
There are similar bug reports in archlinux:
- https://bugs.archlinux.org/task/35520
- https://bbs.archlinux.org/viewtopic.php?id=162955
Comment 1 Adrian Reber 2013-08-02 08:22:54 EDT
Hmm, it works for me. Do you have anything in your log files concerning xlock and authentication failures?
Comment 2 Alick Zhao 2013-08-02 11:30:52 EDT
Below is the output in `journalctl -f _UID=1000` when I type my password twice to unlock:

8月 02 23:20:40 helium xlock[8853]: Start: alick, alick, :1
8月 02 23:20:53 helium xlock[8853]: Stop: alick, alick, :1, 0m 13s

Below is the output when I type the password once, then press enter multiple times and the login attempt fails, then type the password twice to login:

8月 02 23:21:24 helium xlock[8876]: Start: alick, alick, :1
8月 02 23:21:39 helium xlock[8876]: pam_unix(xlock:auth): authentication failure; logname=alick uid=1000 euid=1000 tty=:1 ruser= rhost=  user=alick
8月 02 23:21:41 helium /etc/gdm/Xsession[4991]: (polkit-gnome-authentication-agent-1:5171): polkit-gnome-1-WARNING **: No icon for themed icon with name 'fprint'
8月 02 23:21:43 helium /etc/gdm/Xsession[4991]: [fvwm][ComplexFunction]: <<ERROR>> Grab failed in function EWMHActivateWindowFunc, unable to execute immediate action
8月 02 23:21:44 helium /etc/gdm/Xsession[4991]: [fvwm][ComplexFunction]: <<ERROR>> Grab failed in function FuncFocusWindow, unable to execute immediate action
8月 02 23:22:06 helium unix_chkpwd[8907]: check pass; user unknown
8月 02 23:22:42 helium unix_chkpwd[8916]: check pass; user unknown
8月 02 23:22:42 helium xlock[8876]: pam_unix(xlock:auth): authentication failure; logname=alick uid=1000 euid=1000 tty=:1 ruser= rhost=  user=root
8月 02 23:22:42 helium xlock[8876]: pam_succeed_if(xlock:auth): requirement "uid >= 1000" not met by user "root"
8月 02 23:22:43 helium xlock[8876]: xlock: failed unlock attempt on user alick
8月 02 23:23:26 helium xlock[8876]: Stop: alick, alick, :1, 2m 2s

Here 8月 means August in English FYI.
Comment 3 Alick Zhao 2013-08-02 11:41:15 EDT
Seems like the second time asking for password is to feed it to polkit authentication? 'fprint' is short for finger print, and I do have finger print authentication device on my Lenovo Thinkpad T400. However it is disabled in gnome-control-center.
Comment 4 Alick Zhao 2013-09-11 10:52:11 EDT
Created attachment 796437 [details]
screenshot of xlock debug mode
Comment 5 Alick Zhao 2013-09-11 11:01:18 EDT
I did some more investigation today. When I execute xlock -debug -mode blank, I will get results in the screenshot attached above. Note that in the middle of the black xlock window, there is the second password prompt (密码 in Chinsese). And there is a popup window which asks for authorization by FPrint. I think this might be a problem with polkit on computers with fingerprint device. Is it so?

There is one more wired thing. My default locale is Chineses (zh_CN.UTF-8), and when I execute
    LANG=C xlock -debug -mode blank
the popup window will never show up. Currently I am using this method to walkaround the issue...
Comment 6 Seb L. 2013-12-22 11:50:16 EST
Problem persists in Fedora 20.

Even worse: if xlock is started from another display in a dual-head configuration (e.g. DISPLAY=:0.1), then xlock always fails to unlock the screen after 60 seconds of (failed) password validation.
Comment 7 Seb L. 2013-12-22 11:57:16 EST
P.S.: this is a regression since xlock was working perfectly with Fedora 18
Comment 8 Seb L. 2013-12-22 12:09:41 EST
Created attachment 840377 [details]
xlock never unlocks from :0.1

When started from any DISPLAY other than :0.0 using a non-US locale (e.g.: LANG=fr_FR.utf8, LANG=ja_JP.utf8, etc.), xlock does not show the second password prompt and thus never unlocks.
Comment 10 Seb L. 2013-12-22 18:03:06 EST
Created attachment 840511 [details]
Proposed fix for bug #991010
Comment 11 Fedora Update System 2013-12-23 15:35:04 EST
xlockmore-5.43-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xlockmore-5.43-4.fc19
Comment 12 Adrian Reber 2013-12-23 15:39:07 EST
Thanks for the patch. Applied.
Comment 13 Fedora Update System 2013-12-23 15:39:32 EST
xlockmore-5.43-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xlockmore-5.43-4.fc20
Comment 14 Fedora Update System 2013-12-24 21:36:20 EST
Package xlockmore-5.43-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xlockmore-5.43-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23949/xlockmore-5.43-4.fc19
then log in and leave karma (feedback).
Comment 15 Alick Zhao 2013-12-27 09:58:52 EST
Thanks for the update. I can confirm it is fixed.
Comment 16 Kamae Norihiro 2014-01-04 03:19:27 EST
Same problem with xlockmore-5.43-1.el6 from EPEL 6.
Could also you update them, or should I create a new ticket?
Comment 17 Fedora Update System 2014-01-04 10:22:02 EST
xlockmore-5.43-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/xlockmore-5.43-4.el6
Comment 18 Fedora Update System 2014-01-05 01:01:49 EST
xlockmore-5.43-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2014-01-05 01:05:16 EST
xlockmore-5.43-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2014-01-19 14:05:09 EST
xlockmore-5.43-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.