Bug 991011 - WebDesigner OOTB tasks missing in designer.
WebDesigner OOTB tasks missing in designer.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 07:59 EDT by Marek Baluch
Modified: 2014-08-06 16:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
How to reproduce vid. (947.35 KB, video/webm)
2013-09-04 06:10 EDT, Marek Baluch
no flags Details
reproducer attached by mistake (711.84 KB, video/webm)
2013-09-04 06:14 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-08-01 07:59:43 EDT
Description of problem:

This is a tracker BZ for all the OOtB tasks required for the BPMS 6.0.0 release.

Following tasks should be implemented:
1) REST
2) WebService
3) ESB
Comment 2 Marek Baluch 2013-09-04 06:10:05 EDT
Created attachment 793586 [details]
How to reproduce vid.
Comment 3 Marek Baluch 2013-09-04 06:11:04 EDT
Too bad quality on youtube so I attached the video here.
Comment 4 Marek Baluch 2013-09-04 06:14:18 EDT
Created attachment 793587 [details]
reproducer attached by mistake
Comment 5 Marek Baluch 2013-09-04 06:16:12 EDT
You could not reproduce the issue because you clicked the canvas before you clicked the '+' icon. Why is it required to click the canvas for the changes to take effect?
Comment 6 Marek Baluch 2013-09-04 06:16:47 EDT
argh - wrong BZ.
Comment 7 Marek Baluch 2013-09-04 06:21:24 EDT
Kris, I found REST and WebService. Is there any concrete reason why you omitted the ESB task?
Comment 8 Kris Verlaenen 2013-09-05 20:05:32 EDT
Marek,

The connector to the ESB is implemented as part of SOA platform (SwithYard), and only available if BPMS would be used on top of SOA platform.  Therefore, adding it by default doesn't seem ideal.  We would recommend documenting how to use this instead.

Kris
Comment 9 Marek Baluch 2013-09-06 01:24:26 EDT
Though so. Just didn't want to make any assumptions. Thanks for confirmation!

Note You need to log in before you can comment on or make changes to this bug.