Bug 991029 - seahorse-nautilus is completely broken
seahorse-nautilus is completely broken
Status: CLOSED DUPLICATE of bug 981580
Product: Fedora
Classification: Fedora
Component: seahorse-nautilus (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Rui Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 08:49 EDT by Michael Catanzaro
Modified: 2013-08-15 10:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 845855
Environment:
Last Closed: 2013-08-15 10:04:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Catanzaro 2013-08-01 08:49:40 EDT
+++ This bug was initially created as a clone of Bug #845855 +++

Bug #845855 just got automatically closed, but it's still broken and I don't have permission to reopen the old bug.  Setting the priority to "urgent" as the package seems to be useless until this is solved.  There's two issues here:

1) There is no option to decrypt files.  (In other distros, it shows at the top of the context menu when right-clicking on an encrypted file.)
2) Encryption and signing silently fails.

Cloned bug below.

Description of problem:

seahorse-nautilus rpm does not add option to decrypt file in Nautilus contextual menu.

Version-Release number of selected component (if applicable):

seahorse-nautilus-3.4.0-2.fc17.x86_64

How reproducible:

Juste do a fresh install of seahorse-nautilus on a system where seahorse-plugins was not installed
 
Actual results:

Entry to crypt file is added in Nautilus contextual menu and it is possible to crypt a file. A new file called filename.ext.pgp is created.

Right clicking on this new file filename.ext.pgp, there is no Decrypt entry displayed in Nautilus contextual menu.

Additional info:

seahorse-nautilus obsoletes seahorse-plugins.

If I installed not seahorse-nautilus but seahorse-plugins, this one works fine and I have a "Decrypt" entry available in Nautilus contextual menu.

If after install of seahorse-plugins, I install seahorse-nautilus or update my system with yum, seahorse-plugins is obsoleted by seahorse-nautilus but I still have "Decrypt" entry available in Nautilus contextual menu.

--- Additional comment from Paolo Leoni on 2013-01-16 08:28:48 CST ---

Me too, I have this problem. No solution with forced install of "seahorse-plugins".

--- Additional comment from Mat Booth on 2013-03-03 18:10:19 CST ---



--- Additional comment from Fedora End Of Life on 2013-07-03 23:02:56 CDT ---

This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

--- Additional comment from Michael Catanzaro on 2013-07-04 09:05:29 CDT ---

Still broken in F19.  In addition the Encryption option seems to no longer work in F19, so I guess the whole package is useless now... anyone else getting the same?

--- Additional comment from Fedora End Of Life on 2013-08-01 07:31:57 CDT ---

Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 1 Alexander Ploumistos 2013-08-14 07:32:57 EDT
As stated above, encrypting as well as decrypting in nautilus remains completely broken in F19. I tried running seahorse-tool in a terminal to decrypt a file, but I got this:

(seahorse-tool:3403): GLib-WARNING **: GChildWatchSource: Exit status of a child process was requested but ECHILD was received by waitpid(). Most likely the process is ignoring SIGCHLD, or some other thread is invoking waitpid() with a nonpositive first argument; either behavior can break applications that use g_child_watch_add()/g_spawn_sync() either directly or indirectly.

It was bad enough losing the ability to decrypt and encrypt in gedit in earlier versions, now seahorse and all relative plugins just take up hard disk space.

I've been using gpg(2) for years, so for me it is not that much of a problem, but I've had novice users staring at the screen waiting for something to happen after entering their passphrase...

I have the following packages installed:

Installed Packages
Name        : seahorse
Arch        : x86_64
Version     : 3.8.2
Release     : 1.fc19
Size        : 6.3 M
Repo        : installed
Summary     : A GNOME application for managing encryption keys
URL         : http://projects.gnome.org/seahorse/
License     : GPLv2+ and LGPLv2+
Description : Seahorse is a graphical interface for managing and using encryption keys.
            : It also integrates with nautilus, gedit and other places for encryption
            : operations.  It is a keyring manager.

Name        : seahorse-nautilus
Arch        : x86_64
Version     : 3.8.0
Release     : 1.fc19
Size        : 818 k
Repo        : installed
Summary     : PGP encryption and signing for nautilus
URL         : https://live.gnome.org/Seahorse
License     : GPLv2+
Description : Seahorse nautilus is an extension for nautilus which allows encryption
            : and decryption of OpenPGP files using GnuPG.


Should I take this upstream?
Comment 2 Rui Matos 2013-08-15 10:04:43 EDT

*** This bug has been marked as a duplicate of bug 981580 ***

Note You need to log in before you can comment on or make changes to this bug.