Bug 991047 - nodejs-millstone needs rebuilding due to version dependency for Requires: npm(request)
nodejs-millstone needs rebuilding due to version dependency for Requires: npm...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nodejs-millstone (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 09:20 EDT by marcindulak
Modified: 2013-08-10 16:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: nodejs-millstone-0.5.15-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-10 16:05:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marcindulak 2013-08-01 09:20:41 EDT
Description of problem:

Unable to install nodejs-millstone due to too strict Requires: npm(request)

Version-Release number of selected component (if applicable):

nodejs-millstone-0.5.15-2.fc18.noarch.rpm

How reproducible:


Steps to Reproduce:
1. yum install nodejs-millstone
2.
3.

Actual results:

Error: Package: nodejs-millstone-0.5.15-2.fc18.noarch (updates)
           Requires: npm(request) < 2.15
           Installed: nodejs-request-2.21.0-1.fc18.noarch (@updates)
               npm(request) = 2.21.0

Expected results:

nodejs-millstone installs.

Additional info:

Only Fedora 18 affected. Fedora 19 and Rawhide OK.
Comment 1 Fedora Update System 2013-08-01 09:35:07 EDT
nodejs-millstone-0.5.15-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nodejs-millstone-0.5.15-3.fc18
Comment 2 Fedora Update System 2013-08-02 18:10:48 EDT
Package nodejs-millstone-0.5.15-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nodejs-millstone-0.5.15-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14165/nodejs-millstone-0.5.15-3.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-08-10 16:05:46 EDT
nodejs-millstone-0.5.15-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.