Bug 991165 - Improve row striping to be more dynamic since we can sort on columns after painting the table
Improve row striping to be more dynamic since we can sort on columns after pa...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-08-01 14:44 EDT by Matt Reid
Modified: 2014-06-17 20:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:19:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sorted My Subscriptions Table (38.88 KB, image/png)
2013-08-01 14:44 EDT, Matt Reid
no flags Details
Sorted All Available Subscriptions Table (70.38 KB, image/png)
2013-08-01 14:45 EDT, Matt Reid
no flags Details
Alternate striping (889.60 KB, image/png)
2013-11-05 17:28 EST, Sharath Dwaral
no flags Details

  None (edit)
Description Matt Reid 2013-08-01 14:44:11 EDT
Description of problem:
I'm not sure exactly how our tables work, but it seems to me that the row striping is hard coded to the row, and not a property of the table. The striping looks great when the table first loads, but breaks when you apply any sort that will change the ordering. After a sort you end up with clumps of the gray backed rows and clumps of the white backed rows, the table doesn't update the coloring of the rows as they move around in the table after-the-fact.

Ideally, our sort shading wouldn't be the same color as the one we use for our alternating rows. It makes it a little weird when an entire column has the same background color, and then some of the rows carry that color as their background color throughout. We may be better off removing the sort shading if we can, and just relying on the sort indicator we place in the header cell.

Version-Release number of selected component (if applicable):
subscription-manager-1.9.0-1.git

How reproducible:
Always

Steps to Reproduce:
1. Launch subscription-manager-gui, maximize it
2. Go to All Available Subscriptions and click Update to pull down some available subscriptions
3. Click on Subscription or one of the other column headers to apply a new sort to the table

Actual results:
After applying the new sort, the row striping no longer will be every other row, they'll be clumped up in groups

Expected results:
Row striping to stay consistent as you reorder the table, and be a property of the table, not the row (which it seems to be now?)

Additional info:
Comment 1 Matt Reid 2013-08-01 14:44:45 EDT
Created attachment 781711 [details]
Sorted My Subscriptions Table
Comment 2 Matt Reid 2013-08-01 14:45:09 EDT
Created attachment 781712 [details]
Sorted All Available Subscriptions Table
Comment 3 Alex Wood 2013-10-03 09:55:16 EDT
commit 8e4bfb83e7ce73f5dd8b4590bf0d198373ef6806
Author: Alex Wood <awood@redhat.com>
Date:   Mon Aug 12 10:32:00 2013 -0400

    991165: Refresh row striping after the TreeView is resorted.
Comment 6 Sharath Dwaral 2013-11-05 17:28:43 EST
Created attachment 820051 [details]
Alternate striping

Version 

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.5-1.el7
python-rhsm: 1.10.5-1.el7


Verification:

Please see the attachment, 

In "all available subscriptions" striping is based on stackable group subscriptions (which are the same color). So striping is for alternate groups. In "My subscriptions" the striping is also based on stackable group subscriptions (which are the same color).

Verified
Comment 7 Ludek Smid 2014-06-13 09:19:12 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.