Bug 991229 - [RFE] Implement Location dependent DNS in IdM
[RFE] Implement Location dependent DNS in IdM
Status: CLOSED DUPLICATE of bug 747612
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.6
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 18:20 EDT by Rich Jerrido
Modified: 2013-08-06 03:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 03:25:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Jerrido 2013-08-01 18:20:05 EDT
The RFE is to request 'Location Dependent' DNS views with IdM's packaged DNS server. 

With the default configuraton of DNS with IdM, each IdM server has SRV records that have the same priority/weight. In environments that span multiple physical sites, authentication requests are frequently serviced via an IdM server that is not 'local' to the client. Due to this, logging into applications who use IdM can be at times rather slow, depending on the behavior of the DNS client as well as the network connectivity between sites. 

Example:

Assume the realm of example.com consists of three sites, sites A, B, & C respectively. (These sites could be representative of multiple datacenters, for example)

Site A
- Has IP Subnet of 192.168.0.0/24
- Has IdM server idm01.example.com

Site B
- Has IP Subnet of 192.168.1.0/24
- Has IdM server idm02.example.com

Site C
- Has IP Subnet of 192.168.2.0/24
- Has IdM server idm03.example.com


If one was to query DNS for each we'd get 

$host -t srv _kerberos._udp.example.com
_kerberos._udp.example.com has SRV record 0 100 88 idm01.example.com.
_kerberos._udp.example.com has SRV record 0 100 88 idm02.example.com.
_kerberos._udp.example.com has SRV record 0 100 88 idm03.example.com.

What would be preferred is a mechanism for an administrator to define their 'DNS Topology', where they'd define the above relationship between their Sites, subnets, and the IdM systems within them. This would give the administrator the capability of saying 'clients in Site A prefer to use IdM servers in Site A'.  This can then be implemented within IdM using bind views, to give a view of the zone with the most local IdM server carrying a lower priority/weight (and thus more preferred) than the others. 


Conceptually, a close anology to this would be Active Directory Sites & Services (http://technet.microsoft.com/en-us/library/cc730868.aspx)
Comment 2 Rob Crittenden 2013-08-01 23:06:41 EDT
Seems to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=747612
Comment 3 Martin Kosek 2013-08-06 03:25:47 EDT
Agreed. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 747612 ***

Note You need to log in before you can comment on or make changes to this bug.