Bug 991282 - Fedup and Fedora 19 Btrfs boot error.
Fedup and Fedora 19 Btrfs boot error.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 00:57 EDT by kobe.bbgf
Modified: 2013-09-23 17:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 16:31:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error report. (78.48 KB, text/plain)
2013-08-02 00:57 EDT, kobe.bbgf
no flags Details

  None (edit)
Description kobe.bbgf 2013-08-02 00:57:20 EDT
Created attachment 781851 [details]
Error report.

Description of problem:
When I have tried to upgrade from Fedora 18 to 19 with Fedup, at the moment of booting there is an error with btrfs

"mount: wrong fs type, bad option, bad superblock on /dev/sda3,
[    5.898988] Portatil mount[121]: missing codepage or helper program, or other error
[    5.899536] Portatil mount[121]: In some cases useful info is found in syslog - try
[    5.900109] Portatil mount[121]: dmesg | tail or so.
[    5.896570] Portatil kernel: btrfs: 'root' is not a valid subvolume"t

I managed to upgrade directly from yum, but at the moment of boot same error with the kernel-3.10.3-300.fc19.x86_64, but when I try to boot with any kernel from fc18 no problem.

What it's the problem, please some help.

Version-Release number of selected component (if applicable):
Fedora 19

How reproducible:
Every single time.

Steps to Reproduce:
1.Trying to boot with kernel-3.10.3-300.fc19.x86_64
2.Error

Actual results:
Can't boot with kernel-3.10.3-300.fc19.x86_64

Expected results:
Normal boot.

Additional info:

Here it's my fstab
"UUID=ec03f2a1-4839-441a-8401-357e6b6f3b34 /                       btrfs   subvol=root,compress=lzo      1 1
UUID=e37e0d99-3090-43bb-a19e-b075935cadbd /boot                   ext4    defaults        		1 1
UUID=ec03f2a1-4839-441a-8401-357e6b6f3b34 /home                   btrfs   subvol=home,compress=lzo      1 2
UUID=f307b1bf-dfc5-4445-a9f2-8de99dbbf988 swap                    swap    defaults        		0 0"
Comment 1 Wictor Lund 2013-09-15 08:16:48 EDT
I might have the same problem, fedup can't mount
my multi-device btrfs filesystem.

I noticed the line 
[    5.896570] Portatil kernel: btrfs: 'root' is not a valid subvolume
in the attachment.

When I boot up the unupgraded fedora 18 and run "btrfs subv list /" I get no output. When I run "btrfs subv get-default /" i get the output "ID 5 (FS_TREE)", this suggests that my default subvolume does not have any name, which might be incompatible with newer versions of btrfs.
Comment 2 Josh Boyer 2013-09-18 16:45:37 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 Josef Bacik 2013-09-23 16:31:13 EDT
If you are still seeing issues please try reproducing on btrfs-next and file a bugzilla at bugzilla.kernel.org and set the component to btrfs.
Comment 4 kobe.bbgf 2013-09-23 17:57:54 EDT
Sorry but i can't reproduce the bug beacuse i've done a clean install of Fedora 19 changing the whole filesystem to Ext4.

Note You need to log in before you can comment on or make changes to this bug.