Bug 99133 - sftp in konqueror fails
sftp in konqueror fails
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-14 16:52 EDT by Phil Cyc
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 04:37:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Cyc 2003-07-14 16:52:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
When trying to connect with konqueror via sftp on any ssh server - openssh as
well as ssh - an error message is shown after about a minute that says

> An error occured while loading sftp://user@some.host.tld
> Could not connect to host localhost

and a message window pops up saying

> Error encountered while talking to ssh.

Connecting via command line works w/o problems.

I'm using ssh 3.2.3 and kdebase-3.1-13.


Version-Release number of selected component (if applicable):
kdebase-3.1-13
ssh-3.2.3-1

How reproducible:
Always

Steps to Reproduce:
1. run konqueror
2. try connecting to a server via sftp://user@some.host.tld
3. wait about a minute.
    

Actual Results:  
- Konqueror shows:
> An error occured while loading sftp://user@some.host.tld
> Could not connect to host localhost

- A message pops up:
> Error encountered while talking to ssh.


Expected Results:  Konqueror should display the contents of $user's home
directory on $some.host.tld.


Additional info:

I replaced OpenSSH with ssh 3.2.3 (www.ssh.com). Nothing else changed.
Comment 1 Marcin Garski 2005-10-24 14:45:30 EDT
Can't reproduce it on KDE 3.4.2 on FC 4.
Comment 2 Ngo Than 2005-10-25 04:37:08 EDT
it seems this bug is fixed in KDE 3.4.2 on FC 3/4

Note You need to log in before you can comment on or make changes to this bug.