Bug 991342 - Build python3 package by default
Build python3 package by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pycxx (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Morris
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 03:57 EDT by Thomas Spura
Modified: 2013-08-22 01:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-pycxx-6.2.4-7.20130805svn280.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 22:56:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Spura 2013-08-02 03:57:11 EDT
Please build the python3 package by default.

This blocks the update of python-matplotlib.


diff --git a/python-pycxx.spec b/python-pycxx.spec
index 94c7b56..3a362d1 100644
--- a/python-pycxx.spec
+++ b/python-pycxx.spec
@@ -1,9 +1,12 @@
 %if (0%{?rhel} >= 5)
 %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 %endif
-%global modname pycxx
 
-# Specify '--with=python3' to build the python 3 RPM
+%if 0%{?fedora} > 12
+%global _with_python3 1
+%endif
+
+%global modname pycxx
 
 Name:           python-%{modname}
 Version:        6.2.4
Comment 1 John Morris 2013-08-02 18:15:22 EDT
Hi, Thomas.

I've had some discussion with Michael Droettboom and Julian Taylor (maintainer of the Debian PyCXX package).  They say that upstream has added support for Python3 recently, so I'll need to pull it.

We were discussing a standard means of locating the PyCXX sources, and agreed on the mechanism.  However, upstream never added anything to the discussion, and perhaps while waiting for that we let the subject drop.  I've opened it up again to see what they want to do:  either make the proposed changes and integrate into upstream matplotlib and the Debian package, or hold off.

Let's wait a day or two for more information, and otherwise I'll make the simple update.  Thanks!
Comment 2 Fedora Update System 2013-08-06 11:48:53 EDT
python-pycxx-6.2.4-7.20130805svn280.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-pycxx-6.2.4-7.20130805svn280.fc18
Comment 3 Fedora Update System 2013-08-06 11:49:06 EDT
python-pycxx-6.2.4-7.20130805svn280.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-pycxx-6.2.4-7.20130805svn280.el6
Comment 4 Fedora Update System 2013-08-06 11:49:16 EDT
python-pycxx-6.2.4-7.20130805svn280.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-pycxx-6.2.4-7.20130805svn280.fc19
Comment 5 John Morris 2013-08-06 11:58:15 EDT
Hi, Thomas.

No replies from Michael and Julian, so I made the simple update.  It should appear in testing soon.

        John
Comment 6 John Morris 2013-08-06 12:03:20 EDT
(In reply to Thomas Spura from comment #0)
> Please build the python3 package by default.
> 
> This blocks the update of python-matplotlib.

I looked for a ticket regarding the python-matplotlib update to understand what updates are in progress and to add that this ticket blocks that one, but I couldn't find one.  Can you please point me to one, if it exists?  Thanks-

       John
Comment 7 Thomas Spura 2013-08-06 12:16:00 EDT
(In reply to John Morris from comment #5)
> No replies from Michael and Julian, so I made the simple update.  It should
> appear in testing soon.

Great, thanks for the fast update.

(In reply to John Morris from comment #6)
> (In reply to Thomas Spura from comment #0)
> > Please build the python3 package by default.
> > 
> > This blocks the update of python-matplotlib.
> 
> I looked for a ticket regarding the python-matplotlib update to understand
> what updates are in progress and to add that this ticket blocks that one,
> but I couldn't find one.  Can you please point me to one, if it exists? 

Currently, I handle it locally only. python-numpydoc was just reviewed, so matplotlib should work now. But unfortunately, it seems python3-matplotlib links wrongly to pycxx and an undefined symbol occurs:
/usr/lib64/python3.3/site-packages/matplotlib/_path.cpython-33m.so: undefined symbol: _ZTIN2Py19ExtensionModuleBaseE

Once that is done, I'll built it in rawhide, but I guess that needs to wait until tomorrow...
Comment 8 Fedora Update System 2013-08-06 19:29:12 EDT
Package python-pycxx-6.2.4-7.20130805svn280.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-pycxx-6.2.4-7.20130805svn280.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14304/python-pycxx-6.2.4-7.20130805svn280.fc19
then log in and leave karma (feedback).
Comment 9 John Morris 2013-08-06 23:46:29 EDT
(In reply to Thomas Spura from comment #7)
> (In reply to John Morris from comment #5)
> Currently, I handle it locally only. python-numpydoc was just reviewed, so
> matplotlib should work now. But unfortunately, it seems python3-matplotlib
> links wrongly to pycxx and an undefined symbol occurs:
> /usr/lib64/python3.3/site-packages/matplotlib/_path.cpython-33m.so:
> undefined symbol: _ZTIN2Py19ExtensionModuleBaseE

Sorry I can't shed any light on the undefined symbol.  My python2 package that needs PyCXX, FreeCAD, seems to be ok with the updated package.  If you discover problems with the package, though, please file a bug report.

        John
Comment 10 Thomas Spura 2013-08-07 08:23:43 EDT
(In reply to John Morris from comment #9)
> (In reply to Thomas Spura from comment #7)
> > (In reply to John Morris from comment #5)
> > Currently, I handle it locally only. python-numpydoc was just reviewed, so
> > matplotlib should work now. But unfortunately, it seems python3-matplotlib
> > links wrongly to pycxx and an undefined symbol occurs:
> > /usr/lib64/python3.3/site-packages/matplotlib/_path.cpython-33m.so:
> > undefined symbol: _ZTIN2Py19ExtensionModuleBaseE
> 
> Sorry I can't shed any light on the undefined symbol.  My python2 package
> that needs PyCXX, FreeCAD, seems to be ok with the updated package.  If you
> discover problems with the package, though, please file a bug report.

In matplotlib, there is a check, if we are running on python3 and then the system library is not inspected and linked in. This is now fixed here locally (and reported upstream at [1]).

So it seems python3-pycxx-devel is working like python2-pycxx-devel too.

Thanks!

[1] https://github.com/matplotlib/matplotlib/pull/2282
Comment 11 Fedora Update System 2013-08-14 22:56:22 EDT
python-pycxx-6.2.4-7.20130805svn280.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-08-14 23:00:46 EDT
python-pycxx-6.2.4-7.20130805svn280.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-08-22 01:49:11 EDT
python-pycxx-6.2.4-7.20130805svn280.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.