Bug 991350 - [RHEVM][backend] error message on egine start/restart -> Failed to decrypt value for property AttestationTruststorePass will be used encrypted value: javax.crypto.BadPaddingException: Data must start with zero
[RHEVM][backend] error message on egine start/restart -> Failed to decrypt va...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
high Severity low
: ---
: 3.3.0
Assigned To: Nobody's working on this, feel free to take it
sla
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 04:15 EDT by Martin Pavlik
Modified: 2016-02-10 15:13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 09:13:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log_collector (6.06 MB, application/x-xz)
2013-08-02 04:15 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2013-08-02 04:15:33 EDT
Created attachment 781878 [details]
log_collector

Description of problem:
following error message appears in log on each start/restart of ovirt engine service

2013-08-02 10:03:27,898 ERROR [org.ovirt.engine.core.dal.dbbroker.generic.DBConfigUtils] (ServerService Thread Pool -- 37) Failed to decrypt value for property AttestationTruststorePass will be used encrypted value: javax.crypto.BadPaddingException: Data must start with zero


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.13.master.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. service ovirt-engine restart
2. check /var/log/ovirt-engine/engine.log
3.

Actual results:
error message appears -> engine starts fine

Expected results:
engine starts w/o error message

Additional info:
Comment 1 Doron Fediuck 2013-08-05 09:13:34 EDT
This is not a bug.
DBConfigUtils was designed to fallback to using the current value if decryption fails. So it will issue an error and use the existing value.

Note You need to log in before you can comment on or make changes to this bug.